
(c) 2009 Εθνικό Μετσόβιο Πολυτεχνείο

Υ∆ΡΟΓΝΩΜΩΝ





Υδρογνώµων έκδοση 4
Οδηγός χρήστη (user manual)

by Σ. Κοζάνης, I. Μαρκόνης

Αυτός είναι ο οδηγός χρήστη (User manual) για το λογισµιµό
«Υδρογνώµων» έκδοση 4. Ο οδηγός αυτός υπάρχει και σε
µορφή help file (βοήθεια) για το λογισµικό και µπορείτε να
τον κατεβάσετε από τη διεύθυνση:

http://www.itia.ntua.gr/el/softinfo/28/

µαζί µε το ίδιο το λογισµικό καθώς και το help file.

Ερευνητική οµάδα ΙΤΙΑ http://www.itia.ntua.gr/

Copyright (c) 2009, Εθνικό Μετσόβιο Πολυτεχνείο

Έκδοση κειµένου 1.00





IΠεριεχόµενα

I

(c) 2009 Εθνικό Μετσόβιο Πολυτεχνείο

Περιεχόµενα
0

Μέρος I Για τις οδηγίες χρήσης 2

Μέρος II Γενικά για τον Υδρογνώµονα 4
................................................................................................................................... 51 Βοήθεια - Online help 
................................................................................................................................... 52 Επιλογές ρυθµίσεων 

Μέρος III Καταχώρηση και απεικόνιση δεδοµένων 8
................................................................................................................................... 91 Απεικόνιση δεδοµένων και επεξεργασία τιµών 

................................................................................................................................... 182 ∆ηµιουργία νέας χρονοσειράς - προβολή ιδιοτήτων χρονοσειράς 

................................................................................................................................... 213 Ανάγνωση - εγγραφή - κλείσιµο χρονοσειρών 

................................................................................................................................... 234 Επεξεργασία - εισαγωγή νέων εγγραφών 

................................................................................................................................... 255 Επεξεργασία - αντιγραφή - επικόλληση 

................................................................................................................................... 286 Φίλτρα - επισήµανση - σύντοµα αθροίσµατα 

................................................................................................................................... 317 Σηµαιοθέτηση - προβολή σηµαιών 

................................................................................................................................... 348 Χρήση µενού συντόµευσης (Popup menu) 

Μέρος IV Ποιοτικός έλεγχος δεδοµένων 38
................................................................................................................................... 381 Έλεγχος ακραίων τιµών  
................................................................................................................................... 392 Έλεγχος χρονικής συνέπειας  

Μέρος V Βασική επεξεργασία χρονοσειρών 42
................................................................................................................................... 421 Εργαλείο πολλαπλής επιλογής χρονοσειρών 
................................................................................................................................... 432 Κανονικοποίηση χρονικού βήµατος 
................................................................................................................................... 453 Μετατροπή του βήµατος των χρονοσειρών σε κανονικό (Irregular to strict) 
................................................................................................................................... 464 Συνάθροιση  χρονοσειρών 
................................................................................................................................... 485 Γραµµικές πράξεις µεταξύ των χρονοσειρών 
................................................................................................................................... 496 Επιµερισµός χρονικού βήµατος 
................................................................................................................................... 507 Σύνθετες πράξεις 
................................................................................................................................... 518 ∆ιπλή αθροιστική καµπύλη 

Μέρος VI Υδρολογική επεξεργασία δεδοµένων 58
................................................................................................................................... 581 Υπολογισµός εξάτµισης και δυνητικής εξατµοδιαπνοής 
................................................................................................................................... 622 Παρεµβολές - καµπύλες στάθµης-παροχής / παροχής-στερεοπαροχής 

.......................................................................................................................................................... 65Υπολογισµός παροχής από στάθµη - στερεοπαροχής από παροχή 

.......................................................................................................................................................... 68Κατάρτιση καµπυλών στάθµης-παροχής / παροχής-στερεοπαροχής 
......................................................................................................................................................... 75Υδραυλικές καµπύλες - Καµπύλες επέκτασης
.......................................................................................................................................................... 79Στάθµη - επιφάνεια, όγκος ταµιευτήρα και λοιποί υπολογισµοί 

................................................................................................................................... 823 Παλινδρόµηση - Συµπλήρωση ελλείψεων 
.......................................................................................................................................................... 87Παλινδρόµηση - Βελτιστοποίηση 

................................................................................................................................... 904 Ζυγός - Αδροµερής προσοµοίωση υδρολογικών διεργασιών λεκάνης απορροής 

................................................................................................................................... 985 Καταχώρηση υδροµετρήσεων - Κατάρτιση χρονοσειράς παροχών από υδροµετρήσεις 



Υ∆ΡΟΓΝΩΜΩΝII

(c) 2009 Εθνικό Μετσόβιο Πολυτεχνείο

................................................................................................................................... 1036 Χωρική ολοκλήρωση - Επιφανειακή βροχόπτωση 

Μέρος VII Στατιστική ανάλυση χρονοσειρών 108
................................................................................................................................... 1081 Πυθία - Στατιστική επεξεργασία χρονοσειρών 
................................................................................................................................... 1172 Ανάλυση εξαιρετικών υδρολογικών γεγονότων  
................................................................................................................................... 1193 Όµβρος - Κατάρτιση όµβριων καµπυλών 

Μέρος VIII Γραφήµατα 128
................................................................................................................................... 1281 Προσθήκη χρονοσειρών στα γραφήµατα 
................................................................................................................................... 1292 Αφαίρεση χρονοσειρών από τα γραφήµατα 

Ευρετήριο 131



Μέρος

Για τις οδηγίες χρήσης



Υ∆ΡΟΓΝΩΜΩΝ2

(c) 2009 Εθνικό Μετσόβιο Πολυτεχνείο

1 Για τις οδηγίες χρήσης

Το  παρόν  κείµενο  είναι  οι  οδηγίες  χρήσης  του  λογισµικού  «Υδρογνώµων».
Απαρτίζεται από τις εξής βασικές ενότητες:

1. Γενικά για τον Υδρογνώµονα.
2. Καταχώρηση και απεικόνιση δεδοµένων.
3. Ποιοτικός έλεγχος δεδοµένων. 
4. Βασική επεξεργασία χρονοσειρών.
5. Υδρολογική επεξεργασία χρονοσειρών.
6. Στατιστική ανάλυση χρονοσειρών. 
7. ∆ηµιουργία γραφηµάτων. 

Ο  χρήστης  του  λογισµικού  πρέπει  να  έχει  βασική  εξοικείωση  µε  τον  χειρισµό
εφαρµογών  σε  Microsoft  Windows  καθώς  και  να  είναι  γνώστης  του  επιστηµονικού
αντικειµένου  του  λογισµικού.  Ο  οδηγός  χρήστη  επεξηγεί  βήµατα  υπολογισµών  στο
περιβάλλον του Υδρογνώµονα όχι όµως και το θεωρητικό - µαθηµατικό υπόβαθρο. 
Προτείνεται δε συνεχή χρήση του οδηγού θεωρητικής τεκµηρίωσης όπου αναλύονται
και επεξηγούνται εξαντλητικά όλες οι υπολογιστικές διαδικασίες καθώς και η φυσική
σηµασία  διαφόρων  παραµέτρων.  Ο  οδηγός  θεωρητικής  τεκµηρίωσης  συνοδεύει  το
µοντέλο και εγκαθίσταται µαζί µε την εφαρµογή.
Τα  αντικείµενα  που  παρουσιάζονται  στον  οδηγό  χρήσης  (π.χ.  υδροµετεωρολογικοί
σταθµοί,  χρονοσειρές,  ταµιευτήρες,  κλπ)  περιέχονται  σε  µία  βάση  δεδοµένων  η
οποία κατασκευάστηκε µεταξύ άλλων για τον έλεγχο των λογισµικών και την σύνταξη
του  οδηγού  χρήστης.  Ωστόσο  στην  τυπική  εγκατάσταση  δεν  περιέχονται  αυτά  τα
δεδοµένα  που  φαίνονται  σε  διάφορες  σελίδες  του  οδηγού.  Τα  δεδοµένα  εισάγονται
και αποθηκεύονται µε ευθύνη του χρήστη.



Μέρος
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2 Γενικά για τον Υδρογνώµονα

Ο  «Υδρογνώµων»  ή  «Υδρογνώµονας»  (Αγγλική  ονοµασία:  “Hydrognomon”),  το
σύστηµα  δηλαδή  επεξεργασίας  των  χρονοσειρών  είναι  µία  αυτόνοµη  εφαρµογή
λογισµικού που τρέχει στο περιβάλλον των Microsoft Windows 2000 ή νεότερων (XP,
Vista,  κλπ.).  Πρόκειται  για  ένα  λογισµικό  που  αναπτύσσεται  εντός  του  Ε.Μ.Π.  εδώ
και µία δεκαετία για να καλύψει διάφορες ερευνητικές ανάγκες και η παρούσα έκδοση
(4.0) είναι µετεξέλιξη των παλαιότερων εκδόσεων που έχουν αναπτυχθεί κυρίως για
τα εξής ερευνητικά προγράµµατα:
«Εκσυγχρονισµός  της  εποπτείας  και  διαχείρισης  του  συστήµατος  των  υδατικών
πόρων  ύδρευσης  της  Αθήνας,  1999–2003»  και  «Ολοκληρωµένη  ∆ιαχείριση
Υδατικών  Συστηµάτων  σε  Σύζευξη  µε  Εξελιγµένο  Υπολογιστικό  Σύστηµα
(Ο∆ΥΣΣΕΥΣ),
2003–2006».

Το  εν  λόγω  σύστηµα   πραγµατοποιεί  απλές  (τυπικές  υδρολογικές)  επεξεργασίες,  οι
οποίες  λειτουργούν  βοηθητικά.  Οι  σηµαντικότερες  λειτουργίες  που  επιτελεί  το
σύστηµα είναι οι ακόλουθες:

• Μετατροπή  χρονοσειρών  σε  σταθερό  χρονικό  βήµα  (ως  γνωστόν,  οι
πρωτογενείς  χρονοσειρές  έχουν  κάποια  σταθερότητα,  αλλά  συχνά
παρουσιάζουν  διαταραχές,  η  εξάλειψη  των  οποίων  είναι  αναγκαία  για
περαιτέρω επεξεργασία)

• Εξαγωγή  χρονοσειρών  µεγαλύτερου  χρονικού  βήµατος  (συνάθροιση),  π.χ.
ωριαίων από δεκάλεπτες, ηµερήσιων από ωριαίες, µηνιαίων από ηµερήσιες

• Τυπικοί έλεγχοι συνέπειας όπως ακραίων τιµών και χρονικής συνέπειας��

• Γραµµική  παλινδρόµηση  µεταξύ  χρονοσειρών,  πολλαπλή  παλινδρόµηση,
οργανική συσχέτιση και αυτοσυσχέτιση

• Υδατικά  ισοζύγια:  αδροµερές  µοντέλο  βροχής  – απορροής  (Το  συγκεκριµένο
υποσύστηµα είναι γνωστό και ως «Ζυγός»)

• Συµπλήρωση  ελλειπουσών  τιµών  µε  χρήση  της  γραµµικής  παλινδρόµησης,
δυνατότητα  εισαγωγή  τυχαίου  όρου  για  διατήρηση  των  στατιστικών
χαρακτηριστικών. Επέκταση χρονοσειρών

• Γραµµικές πράξεις µεταξύ χρονοσειρών

• Κατάρτιση  καµπυλών  στάθµης  –  παροχής  µε  στατιστικές  µεθόδους  και
καµπυλών επέκτασης µε χρησιµοποίηση υδραυλικών εξισώσεων

• Εξαγωγή  χρονοσειρών  παροχών  από  χρονοσειρές  στάθµης,  καθώς  και
χρονοσειρών  όγκου  και  επιφανείας  από  χρονοσειρές  στάθµης  ταµιευτήρων
και λιµνών
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• Υπολογισµός  εξάτµισης  και  δυνητικής  εξατµοδιαπνοής  µε  αναλυτικές  ή
ηµιεµπειρικές µεθόδους

• Επέκταση δειγµάτων εξατµοδιαπνοής

• Εύρεση  στατιστικών  χαρακτηριστικών  δείγµατος  χρονοσειράς,  προσαρµογή
στατιστικών  παραµέτρων,  στατιστικές  προγνώσεις,  στατιστικοί  έλεγχοι  και
εύρεση  διαστηµάτων  εµπιστοσύνης.  (Το  συγκεκριµένο  υποσύστηµα  είναι
γνωστό και ως «Πυθία»)

• Ανάλυση  χρονοσειρών  εξαιρετικών  βροχοπτώσεων  -  κατάρτιση  οµβρίων
καµπυλών  µε  συνεπείς  µεθοδολογίες.  (Το  συγκεκριµένο  υποσύστηµα  είναι
γνωστό και ως «Όµβρος»).

2.1 Βοήθεια - Online help

Η  βοήθεια  του  Υδρογνώµονα  καλείται  ανά  πάσα  στιγµή  µέσω  της  επιλογής  των
µενού "Help": 

Επιπλέον,  η  βοήθεια  καλείται  µε  χρήση  του  πλήκτρου  "F1"  το  οποίο  ενεργοποιεί
µάλιστα  "Context  sensitive  help",  δηλαδή  ανοίγει  θέµα  βοήθειας  σχετικό  µε  την
τρέχουσα φόρµα του Υδρογνώµων.
Το  κείµενο  της  βοήθειας  εκδίδεται  και  σε  µορφή  τυπωµένου  οδηγού  χρήστη  (user
manual)  και  διατίθεται  στους  χρήστες  σε  µορφή  PDF  (Adobe  Acrobat).  Τα  αρχεία
PDF  των  οδηγιών  χρήσης  εγκαθίστανται  στους  υπολογιστές  των  χρηστών  κατά  την
εγκατάσταση των εφαρµογών λογισµικού.

2.2 Επιλογές ρυθµίσεων

Χρησιµοποιώντας το µενού File→Preferences εµφανίζεται η φόρµα των ρυθµίσεων:
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στην οποία καθορίζονται οι εξής ρυθµίσεις του λογισµικού:

• Η Default (System local) ρυθµίζει αυτόµατα την γλώσσα του λογισµικού σύµφωνα
µε  τις  τοπικές  ρυθµίσεις  των  Microsoft  Windows.  Ο  χρήστης  µπορεί  να  επιλέξει
ρητά, ώστε να χρησιµοποιηθεί κάποια γλώσσα από την παραπάνω λίστα. 

• Ενεργοποίηση  µηνύµατος  προειδοποίησης  κατά  την  έξοδο  από  το  λογισµικό
(Confirmation for exiting Hydrognomon).

• Συσχέτιση των αρχείων τύπου .ydr µε το λογισµικό του Υδρογνόµων.

Για να τεθούν σε λειτουργία οι µεταβολές των ρυθµίσεων από το χρήστη χρειάζεται η
επανεκκίνηση της εφαρµογής.



Μέρος

Καταχώρηση και απεικόνιση δεδοµένων
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3 Καταχώρηση και απεικόνιση δεδοµένων

Το  σύνολο  σχεδόν  των  επεξεργασιών  εκτελείται  µέσω  ενός  κοινού  γραφικού
περιβάλλοντος  (user  interface)  το  οποίο  ονοµάζεται  «πλέγµα  χρονοσειρών»  ή  "
time  series  grid"  το  οποίο  παραπέµπει  σε  προγράµµατα  τύπου  spreadsheets
(λογιστικά  φύλα)  όπως  το  Microsoft  Excel·  οι  περισσότεροι  χρήστες  είναι
εξοικειωµένοι  µε  αυτού  του  τύπου  το  περιβάλλον,  επιπλέον  δίνεται  η  δυνατότητα
ανταλλαγής δεδοµένων µε προγράµµατα τύπου Microsoft Excel.

Η οθόνη διαχείρισης δεδοµένων χωρίζεται σε τέσσερις περιοχές:

• Η  περιοχή  µε  τα  δεδοµένα  των  χρονοσειρών.  Η  απεικόνιση  των
δεδοµένων  γίνεται  είτε  µε  την  µορφή  «κορδονιού»  είτε  µε  την  µορφή
«ηµερολογιακού  πίνακα».  Στην  πρώτη  περίπτωση  επιτρέπεται  η  πολλαπλή
απεικόνιση  πολλών  χρονοσειρών  µε  κοινές  µετρήσεις  σε  συγκεκριµένες
χρονικές  στιγµές.  Στην  δεύτερη  περίπτωση  απεικονίζεται  µία  χρονοσειρά  σε
µορφή ηµερολογιακού πίνακα. Οι στήλες αντιστοιχούν στους µήνες του έτους
ενώ οι γραµµές στις ηµέρες του µήνα ή στα έτη αναλόγως αν η απεικονισµένη
χρονοσειρά είναι µηνιαίου ή ηµερήσιου χρονικού βήµατος.

• Η µπάρα µε τα κουµπιά. Στην µπάρα µε τα κουµπιά αναπαράγονται κάποιες
βασικές λειτουργίες τις οποίες ο χρήστης µπορεί να βρει και στα µενού.

• Η  µπάρα  των  µενού.  Στην  µπάρα  των  µενού  περιλαµβάνονται  όλες  οι
λειτουργίες  της  φόρµας.  Εκτός  από  τα  βασικά  µενού  του  περιβάλλοντος  του
Υδρογνώµονα  περιλαµβάνονται  επιπρόσθετα  τα  µενού  File,  Edit,  View,
Series, Hydrology και Help.

• H  µπάρα  κατάστασης.  Στην  µπάρα  κατάστασης  εµφανίζονται  ορισµένα
µηνύµατα του συστήµατος καθώς και βοηθητικά µηνύµατα (tooltips).
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Πολλαπλή απεικόνιση χρονοσειρών (α) και απεικόνιση µοναδιαίας χρονοσειράς σε
µορφή ηµερολογιακού πίνακα (β).

3.1 Απεικόνιση δεδοµένων και επεξεργασία τιµών

Ανοίγοντας µία χρονοσειρά ή δηµιουργώντας µία νέα χρονοσειρά, ο συνήθης τρόπος
απεικόνισης είναι ο παρακάτω:
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∆ύο  στήλες  εµφανίζονται.  Η  αριστερή  στήλη  περιλαµβάνει  µία  αύξουσα  σειρά  από
ηµεροµηνίες ενώ η δεξιά στήλη τις τιµές που αντιστοιχούν στις χρονικές στιγµές της
αριστερής  στήλης.  Η  στήλη  µε  τις  τιµές  µπορεί  να  περιλαµβάνει  αριθµητικές  τιµές  ή
κενά.  Τα  κενά  (null  values)  αντιπροσωπεύουν  προβληµατικές  ή  ελλείπουσες
µετρήσεις ή αδυναµία υπολογισµού κάποιας τιµής που προέρχεται από επεξεργασία.
Ο χρήστης µπορεί να επέµβει σε κάποια αριθµητική τιµή πηγαίνοντας µε το ποντίκι ή
το πληκτρολόγιο πάνω της. Στην συνέχεια µπορεί να πατήσει F2, ή διπλό κλίκ, ή να
ξεκινήσει και να γράφει την τιµή κατευθείαν. Εναλλακτικά µπορεί να χρησιµοποιήσει
την  επιλογή  του  µενού  "Edit  /  Set  value...  Ctrl+F2"  σε  µία  ή  και  σε  περισσότερες
επιλεγµένες τιµές:

→ →
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→

Επιπλέον,  υπάρχει  η  δυνατότητα  να  τεθεί  η  τιµή  ως  «κενή» (ή  έλλειψη)  σβήνοντας
απλά  την  αριθµητική  τιµή  ή  χρησιµοποιώντας  την  λειτουργία  των  µενού:  "Edit→Set
Null",  σε  µία  ή  και  περισσότερες  εγγραφές  όπως  γίνεται  και  στην  παραπάνω
περίπτωση (Set value σε περισσότερες της µίας εγγραφές)
Η  µορφή  απεικόνισης  των  ηµεροµηνιών  συναρτάται  µε  το  χρονικό  βήµα  της
χρονοσειράς.
Για  τις  χρονοσειρές  δεκάλεπτου,  ωριαίου  και  ηµερήσιου  χρονικού  βήµατος,  καθώς
και για τις χρονοσειρές ακανόνιστου βήµατος η απεικόνιση γινεται όπως παρακάτω:

Στην συγκεκριµένη περίπτωση το χρονικό βήµα είναι ωριαίο. Η απεικόνιση γίνεται µε
αντίστροφη  σειρά  δηλαδή  έτος,  µήνας,  ηµέρα,  ώρα,  λεπτά.  Ειδικά  για  τις
χρονοσειρές αθροιστικής µεταβλητής (όπως η βροχόπτωση, η διάρκεια ηλιοφάνειας,
η  απορροή  και  η  δυνητική  εξατµοδιαπνοή)  η  χρονική  στιγµή  που  απεικονίζεται
αντιπροσωπεύει  το  τέλος  της  µέτρησης.  Έχοντας  το  παραπάνω  παράδειγµα,  η
βροχόπτωση  που  καταγράφεται  την  χρονική  στιµή  1994/02/19  18:00,
αντιπροσωπεύει  το  ύψος  βροχόπτωσης  που  καταγράφηκε  µεταξύ  1994/02/19
17:00:01  και  1994/02/19  18:00:00.  Αυτό  το  σηµείο  χρειάζεται  ιδιαίτερη  προσοχή
καθώς δεν συµβαβίζει πάντα µε την κοινή αντίληψη.
Οι µηνιαίες χρονοσειρές απεικονίζονται όπως παρακάτω:

Εµφανίζεται το έτος και ο µήνας (ως εεεε/µµ) ενώ η µέτρηση που αντιστοιχεί σε κάθε
γραµµή είναι αντιπροσωπευτική για όλο τον µήνα. (Για παράδειγµα η µέτρηση στον
µήνα  1907/10  αντιπροσωπεύει  π.χ.  το  ύψος  βροχόπτωσης  του  Οκτωβρίου  του
1907).
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Οι  ετήσιες  χρονοσειρές  απεικονίζονται  αναλόγως  αν  η  χρονοσειρά  αναφέρεται  σε
ηµερολογιακό  (µε  αρχή  την  1η  Ιανουαρίου)  ή  υδρολογικό  (µε  αρχή  την  1η
Οκτωβρίου) έτος:

 ή 
Όπως  και  στις  χρονοσειρές  µε  µηνιαίο  χρονικό  βήµα,  έτσι  και  στις  ετήσιες
χρονοσειρές,  οι  µετρήσεις  αντιπροσωπεύουν  όλο  το  έτος  που  απεικονίζεται,  έτσι  η
µέτρηση στο 1997 αφορά π.χ. την βροχόπτωση όλου του έτους 1997.
Η  πολλαπλή  απεικόνιση  χρονοσειρών  επιτρέπεται  ακόµα  και  αν  τα  χρονικά  βήµατα
των  χρονοσειρών  διαφέρουν.  Παρακάτω,  εµφανίζονται  τρεις  χρονοσειρές,  µία
ετησίου, µία µηνιαίου και µία ηµερησίου χρονικού βήµατος:

Όπως  φαίνεται  στο  παραπάνω  σχήµα,  οι  µετρήσεις  σε  διαφορετικές  χρονικές
κλίµακες δεν συµπίπτουν, διατηρείται ωστόσο συνέπεια στην χρονική αλληλουχία. Οι
τιµές  που  εµφανίζονται  µε  έντονα  γράµµατα  (bold)  είναι  νέες  τιµές  και  έχουν



Καταχώρηση και απεικόνιση δεδοµένων 13

(c) 2009 Εθνικό Μετσόβιο Πολυτεχνείο

προκύψει  από  την  επεξεργασία  της  συνάθροισης.  Οι  τιµές  εµφανίζονται  µε  πλάγια
γράµµατα, όταν είναι τροποποιηµένες από τον χρήστη ή τροποποιηθούν από κάποια
επεξεργασία.

Τροποποιηµένη χρονοσειρά (modified)
Εάν  ο  χρήστης  έχει  τροποποιήσει  τιµές  της  χρονοσειράς  ή  αν  δηµιουργηθεί  νέα
χρονοσειρά  τότε  η  χρονοσειρά  θεωρείται  ως  «τροποποιηµένη»  (modified).  Η
επισήµανση  "modified"  θα  φαίνεται  στο  κελί  του  τίτλου  της  χρονοσειράς.  Εάν  ο
χρήστης  αποθηκεύσει  τις  αλλαγές  η  επισήµανση  θα  αναιρεθεί.  Αν  υπάρχουν
ανοιγµένες  χρονοσειρές  µε  την  επισήµανση  της  τροποποιηµένης  χρονοσειράς  και
επιχειρηθεί στην συνέχεια κλείσιµο του περιβάλλοντος επεξεργασίας, το σύστηµα θα
ενηµερώσει τον χρήστη για τυχόν αλλαγές που δεν έχουν αποθηκευτεί:

Η έννοια της ενεργής χρονοσειράς
Ενεργή χρονοσειρά θεωρείται αυτή από την οποία έχει επιλεγεί µία τουλάχιστον τιµή
(η  οποία  θα  απεικονίζεται  µε  µπλε  χρώµα).  Στην  περίπτωση  επιλογής  πολλών
χρονοσειρών στην σειρά, η πρώτη χρονοσειρά της σειράς θεωρείται ως ενεργή. Μία
πληθώρα  επεξεργασιών  γίνονται  πάνω  στην  ενεργή  χρονοσειρά.  Στην  περίπτωση
που απαιτείται πλέον της µίας χρονοσειράς τότε χρησιµοποιείται ειδικό περιβάλλον.

Απεικόνιση σε µορφή ηµερολογιακού πίνακα
Για  τις  χρονοσειρές  µηνιαίου,  ηµερησίου  και  ωριαίου  χρονικού  βήµατος,  δίνεται  η
δυνατότητα απεικόνισης των τιµών σε διατεταγµένο ηµερολογιακό πίνακα. Σε αυτήν
την  περίπτωση  απεικονίζεται  µία  µοναδιαία  χρονοσειρά  όπου  η  στήλες
αντιπροσωπεύουν  τους  µήνες  του  έτους  ενώ  οι  γραµµές  τα  έτη  για  τις  µηνιαίες
χρονοσειρές  και  τις  ηµέρες  του  µήνα  συγκεκριµένου  έτους  για  τις  ηµερήσιες
χρονοσειρές. Για τις ωριαίες χρονοσειρές ο πίνακας είναι 24 γραµµών (ώρες) και 31
στηλών (ηµέρες), κάθε πίνακας αναφέρεται σε συγκεκριµένο µήνα έτους.

Για να απεικονιστεί µία χρονοσειρά σε ηµερολογιακό πίνακα πρέπει να έχει αυστηρό
χρονικό  βήµα  (time step strict).  Η  λειτουργία  της  απεικόνισης  ενεργοποιείται  είτε
µε το κουµπί "Table" είτε µέσω της λειτουργίας µενού View→As Table (πλήκτρο F7
).  Αν  είναι  πλέον  της  µίας  χρονοσειράς  φορτωµένη,  η  ενεργή  χρονοσειρά
απεικονίζεται ως πίνακας:
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Παραπάνω είναι η απεικόνιση µίας χρονοσειράς µηνιαίου χρονικού βήµατος. Όταν η
χρονοσειρά έχει ηµερήσιο χρονικό βήµα, απεικονίζεται ένας πίνακας κατά έτος:
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Ο παραπάνω πίνακας αναφέρεται στις ηµέρες του έτους 1967. Για να απεικονιστούν
οι  τιµές  των  υπολοίπων  ετών  ο  χρήστης  χρησιµοποιεί  τα  κουµπιά  "Previous"  και  "
Next" από την µπάρα µε τα κουµπιά:

Τέλος,  σε  χρονοσειρές  ωριαίου  χρονικού  βήµατος,  απεικονίζεται  συγκεκριµένος
µήνας  έτους.  Στο  παρακάτω  παράδειγµα  απεικονίζονται  οι  ωριαίες  τιµές  του  Μαΐου
του 2001. Οι στήλες είναι 24 (αρίθµηση 00:00 - 23:00) ενώ οι γραµµές 31 (ο αριθµός
των ηµερών εξαρτάται από το µήνα του έτους).
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Σε µία επιπλέον γραµµή και µία επιπλέον στήλη εµφανίζεται η µέση τιµή κάθε στήλης
και  κάθε  γραµµής.  Αν  η  µεταβλητή  έχει  δηλωθεί  ως  αθροιστική  µεταβλητή
(cumulative)  οι  συνοπτικές  στήλες  /  γραµµές  θα  απεικονίζουν  τα  αθροίσµατα
γραµµών και στηλών αντίστοιχα αντί των µέσων τιµών.
Συµπληρωµατικά  στις  συνοπτικές  στήλες  των  στατιστικών,  δίνεται  η  δυνατότητα
εµφάνισης  ανεπτυγµένων  στατιστικών  κάνοντας  χρήση  του  µενού  "View→Show
statistics":

Εµφανίζονται τα ανεπτυγµένα στατιστικά:
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Τα στατιστικά αναλύονται ως εξής:

• Mean: Η µέση τιµή του δείγµατος (στήλη ή γραµµή).

• Standard deviation: Η τυπική απόκλιση.

• Variance coefficient: Η τυπική απόκλιση αφού διαιρεθεί µε την µέση τιµή.

• Number of values: Η µη-κενές τιµές.

• Missing values: Οι ελλείψεις (κενές τιµές).

• Maximum  /  Minimum  value:  Η  µέγιστη  /  ελάχιστη  τιµή  κατά  στήλη  και
γραµµή.

• Upper  /  Lower  limit:  Άνω  /  κάτω  όριο  που  περικλείουν  το  ~99%  βάσει  της
κανονικής  κατανοµής  (άνω/κάτω  όριο  =  µ±3σ  όπου  µ  η  µέση  τιµή  του
δείγµατος και σ η τυπική απόκλιση).

• High / Low values: Ο αριθµός των τιµών που παραβιάζουν τα άνω και κάτω
όρια (Upper / Lower limit).

Τέλος, µέσω της επιλογής του µενού "View→Hydrological year":



Υ∆ΡΟΓΝΩΜΩΝ18

(c) 2009 Εθνικό Μετσόβιο Πολυτεχνείο

Οι  µήνες  ξεκινάνε  από  τον  Οκτώβριο  (αρχή  υδρολογικού  έτους)  και  τα  έτη
παρουσιάζονται στην µορφή εεεε-εε:

3.2 ∆ηµιουργία νέας χρονοσειράς - προβολή ιδιοτήτων χρονοσειράς

Ο χρήστης επιλέγει το µενού: "File→New":
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Ένα  νέο  παράθυρο  ανοίγει  στο  οποίο  ο  χρήστης  πρέπει  να  καθορίσει  τις  ιδιότητες
της νεάς χρονοσειράς:

Oι παραπάνω ιδιότητες χαρακτηρίζουν την χρονοσειρά και αναλύονται ως:

• Time  step  (Χρονικό  βήµα):  Το  χρονικό  βήµα  από  µία  λίστα  δυνατοτήτων
όπως "δεκάλεπτο", "ωριαίο", κλπ.

• Time step is strict (Αυστηρό χρονικό βήµα): Το χρονικό βήµα είναι σταθερό
και δεν ολισθαίνει.

• Uses hydrological year (Χρήση υδρολογικού έτους): Σε ετήσιες χρονοσειρές
το  υδρολογικό  έτος  αναφέρεται  στο  έτος  µεταξύ  Οκτωβρίου  και  Σεπτεµβρίου
του επόµενου έτους.

• Date offset  (Χρονική  ολίσθηση  σε  λεπτά):  Η  σταθερή  χρονική  ολίσθηση  έχει
νόηµα  µόνο  σε  χρονοσειρές  αυστηρού  χρονικού  βήµατος.  Ένα  τυπικό
παράδειγµα  είναι  οι  καθηµερινές  µετρήσεις  βροχόπτωσης  όχι  στην  αρχή  της
ηµέρας (00:00) αλλά σε µία συγκεκριµένη ώρα, π.χ. 08:00.

• Variable  type  (Τύπος  µεταβλητής):  Ο  τύπος  µεταβλητής  µπορεί  να  είναι
αθροιστικός, στιγµιαίος, µέσων τιµών, µεγίστων, ελαχίστων και διανυσµατικός.

• Unit  (Μονάδα  µέτρησης):  Η  µονάδα  µέτρησης  είναι  µία  αλφαριθµητική  τιµή,
ενδεικτική του φυσικού µεγέθους που αντιπροσωπεύει η χρονοσειρά.

• Display title (Τίτλος): Ένας περιγραφικός τίτλος της χρονοσειράς.
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• Display  comment  (Σχόλια):  Σχόλια  που  περιέχουν  περισσότερες
πληροφορίες για την χρονοσειρά.

• Precision (Ακρίβεια): Η ακρίβεια είναι ένας ακέραιος αριθµός που περιγράφει
τον σταθερό αριθµό δεκαδικών ψηφίων.

Τα σχόλια (comments) εµφανίζονται σαν ετικέτα (tooltip) όταν ο χρήστης δείχνει µε το
ποντίκι τον τίτλο της χρονοσειράς όπως στο παρακάτω σχήµα:

Αφού δηµιουργηθεί η νέα χρονοσειρά τελικά, παρουσιάζεται ως κενή στήλη:

Προβολή ιδιοτήτων χρονοσειράς
Για  την  προβολή  των  ιδιοτήτων  χρονοσειράς  χρησιµοποιείται  το  ίδιο  παράθυρο
διαλόγου  µε  αυτό  για  την  δηµιουργία  νέας  χρονοσειράς.  Ο  χρήστης  φορτώνει  µία
χρονοσειρά, κατόπιν επιλέγει το µενού: "File→Series Properties...":

Το παράθυρο διαλόγου µε τις ιδιότητες χρονοσειράς ανοίγει:



Καταχώρηση και απεικόνιση δεδοµένων 21

(c) 2009 Εθνικό Μετσόβιο Πολυτεχνείο

3.3 Ανάγνωση - εγγραφή - κλείσιµο χρονοσειρών

Οι  λειτουργίες  ανάγνωσης  ενεργοποιούνται  είται  µέσω  της  µπάρας  κουµπιών  είτε
µέσω των επιλογών του µενού "File":

Χρησιµοποιώντας  τα  κουµπιά  Load  time  series  from  file/Save  time  series  ή  τα
µενού File→Open from file/Save, ο χρήστης διαβάζει ή γράφει αντίστοιχα δεδοµένα
χρονοσειράς  από/σε  αρχείο.  Σε  αυτές  τις  περιπτώσεις  χρησιµοποιείται  ο  τυπικός
διαχειριστής αρχείων του λειτουργικού συστήµατος για να υποστηριχθεί η λειτουργία:
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Επίσης  ο  χρήστης  µπορεί  να  ανοίξει  απευθείας  από  τον  Windows  Explorer  ένα  ή
περισσότερα αρχεία τύπου .hts (hydrognomon time series file) επιλέγοντας τα µε τo
ποντίκι και πατώντας Enter ή µπορεί  ακόµα και να τα ανοίξει  "τραβώντας" τα πάνω
στον υδρογνώµονα. 

Τέλος  µε  χρήση  του  κουµπιού/µενού  "Close  selected  time  series"  (File→Close
time  series),  κλείνει  η  ενεργός  (επιλεγµένη)  χρονοσειρά  ή  και  οι  χρονοσειρές  που
περιλαµβάνονται σε µία πολλαπλή επιλογή. 

Η  προκαθορισµένη  (default)  µορφή  αρχείων  που  ανοίγουν  στο  περιβάλλον  του
Υδρογνώµονα είναι τα αρχεία χρονοσειρών µε κατάληξη (file extension) *.hts. Μέσω
του  File->Open  δίνεται  η  επιλογή  στον  χρήστη  για  άνοιγµα  αρχείων  *.hts,  *.txt  ή
οποιουδήποτε τύπου αρχείων.

Μία  άλλη  µέθοδος  για  να  ανοίξουν  αρχεία  χρονοσειρών  είναι  να  τα  «σύρετε»  από
οποιαδήποτε  τοποθεσία  του  υπολογιστή  σας  «µέσα»  στο  παράθυρο  του
Υδρογνώµονα, ενέργεια που είναι γνωστή και ως “Drag’n drop”.

Με  τα  αρχεία  τύπου  *.hts  (αρχεία  χρονοσειρών)  δηµιουργείται  συσχέτιση  στο
λειτουργικό  σύστηµα  έτσι  ώστε  αν  επιλέξετε  κάποιο  αρχείο  *.hts  και  στην  συνέχεια
κάνετε είτε διπλό κλίκ, είτε πατήσετε Enter είτε δεξί κουµπί mouse και στη συνέχεια “
Open”,  το  αρχείο  ανοίγει  στο  περιβάλλον  του  Υδρογνώµονα.  ∆ίδεται  επιπλέον  η
δυνατότητα να επιλεχθούν πολλαπλά αρχεία και αυτά να ανοίξουν ταυτόχρονα στον
Υδρογνώµονα.

Η συσχέτιση των αρχείων  *.hts γίνεται  αυτόµατα την πρώτη φορά που  θα  εκκινήσει
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το λογισµικό. Ο χρήστης ενηµερώνεται από το σύστηµα πως έχει τεθεί η συσχέτιση.
Στην περίπτωση που ο χρήστης εγκαταστήσει ένα δεύτερο, τρίτο, κλπ αντίγραφο του
Υδρογνώµονα,  τότε  στην  αντίστοιχη  εκκίνηση  ενηµερώνεται  ο  χρήστης  πως  η
τοποθεσία του λογισµικού πιθανώς να έχει αλλάξει. Ο χρήστης θα ερωτηθεί αν θέλει
να  αποδεχθεί  τη  νέα  θέση  του  λογισµικού  ώστε  τα  αρχεία  *.hts  να  ανοίγουν  µε  τη
νέα.  Αντίστοιχος  έλεγχος  γίνεται  για  την  περίπτωση  που  τα  αρχεία  *.hts  έχουν
συσχετιστεί µε διαφορετικό λογισµικό του Υδρογνώµονα.

Τα αρχεία *.hts εµφανίζονται στο σύστηµα µε το παρακάτω εικονίδιο:    

3.4 Επεξεργασία - εισαγωγή νέων εγγραφών

Ανεξάρτητα  µε  το  αν  η  χρονοσειρά  είναι  κενή  (π.χ.  νέα  χρονοσειρά)  ή  έχει  ήδη
εγγραφές,  ο  χρήστης  είναι  σε  θέση  να  εισάγει  χειροκίνητα  νέες  εγγραφές.  Μία  νέα
εγγραφή κατά το στάδιο της δηµιουργίας της είναι κενή εγγραφή. Ο χρήστης µπορεί
στην συνέχεια να συµπληρώσει κάποια αριθµητική τιµή ή να εισάγει δεδοµένα µέσω
του  Microsoft  Windows  clipboard  αντιγράφοντας  αριθµητικές  τιµές  π.χ.  από  το
Microsoft  Excel.  Η  εισαγωγή  µοναδιαίας  εγγραφής  σε  συγκεκριµένη  ηµεροµηνία
γίνεται µε τον παρακάτω τρόπο:

→ →

Εάν η εγγραφή υπάρχει ήδη επιστρέφεται µήνυµα λάθους:

Οι ηµεροµηνίες των εγγραφών πρέπει να έχουν τις εξής µορφές:

• 2004/12/18  01:23,  για  χρονοσειρές  ακανόνιστου,  δεκάλεπτου,  ωριαίου  και
ηµερήσιου χρονικού βήµατος
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• 2004/12, για χρονοσειρές µηνιαίου χρονικού βήµατος

• 2004, για χρονοσειρές ετησίου χρονικού βήµατος

• 2004/10,  για  χρονοσειρές  µε  ετήσιο  χρονικό  βήµα  /  υδρολογικό  έτος.  Στην
συγκεκριµένη περίπτωση η εγγραφή 2004/10 (Οκτ. 2004) αντιπροσωπεύει το
υδρολογικό έτος 2004-05. 

Σε κάθε περίπτωση που η εγγραφή δεν είναι συµβατή µε το χρονικό βήµα / χρονική
µετατόπιση το σύστηµα επιστρέφει το παρακάτω µήνυµα λάθους:

Εισαγωγή πολλαπλών εγγραφών
Η εισαγωγή εγγραφών µία προς µία όπως παραπάνω είναι δύσχρηστη όταν πρέπει
να  εισαχθεί  ένα  πλήθος  εγγραφών.  Το  πρόβληµα  αυτό  αντιµετωπίζεται  µε  την
δυνατότητα  εισαγωγής  πολλαπλών  εγγραφών.  Αυτό  προυποθέτει  πως  υπάρχει
τουλάχιστον  µία  εγγραφή  η  οποία  µπορεί  να  εισαχθεί  όπως  παραπάνω.  Στην
συνέχεια  ο  χρήστης  καθορίζει  τον  ακέραιο  αριθµό  νέων  εγγραφών  που
τοποθετούνται  στην  «ουρά»  (τέλος)  της  χρονοσειράς.  Η  διαδικασία  παρουσιάζεται
σχηµατικά στην συνέχεια:

→ →

→
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3.5 Επεξεργασία - αντιγραφή - επικόλληση

Το  σύστηµα  αντιγραφής  και  επικόλλησης  προς  και  από  το  Microsoft  Windows
clipboard  παρέχει  δυνατότητες  συνεργασίας  του  συστήµατος  του  Υδρογνώµονα  µε
λογισιµικά όπως το Microsoft Excel και κάθε άλλη παρόµοια εφαρµογή.

Επιλογή δεδοµένων
Ο χρήστης µπορεί  να χρησιµοποιεί  το µενού: "Edit→Select entire time series" για
να  επιλέξει  όλες  τις  εγγραφές  (συµπεριλαµβανοµένων  και  των  τιµών)  µίας
χρονοσειράς. Αυτό µπορεί να γίνει πατώντας µε το ποντίκι στο κελί µε τον τίτλο της
χρονοσειράς:

Πατώντας µε το ποντίκι  στην πρώτη στήλη (κελιά ηµεροµηνιών) σε κάποια γραµµή,
επιλέγονται όλες οι τιµές από διαφορετικές χρονοσειρές:

Τέλος  ο  χρήστης  µπορεί  να  επιλέξει  µία  αυθαίρετη  περιοχή  που  να  περιλαµβάνει
δεδοµένα από πολλές χρονοσειρές:
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Αντιγραφή δεδοµένων
Τα δεδοµένα αντιγράφονται είτε περιλαµβάνοντας τις ηµεροµηνίες (Edit→Copy with
dates) είτε χωρίς ηµεροµηνίες - µόνο τις τιµές (values). Η αντιγραφή µπορεί να γίνει
είτε από µία χρονοσειρά  είτε από πολλές χρονοσειρές  ταυτοχρόνως ή και από τους
ηµερολογιακούς πίνακες χρονοσειρών.
Βήµα 1: Ο χρήστης επιλέγει κάποια δεδοµένα:

Βήµα 2: Χρήση µενού: "Edit→Copy" ή "Edit→Copy with dates":
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Βήµα 3: Επικόληση των αποτελεσµάτων π.χ. στο Micosoft Excel:

Στο  παραπάνω  παράδειγµα,  στις  στήλες  A  και  B  είναι  επικολληµένα  τα
αποτελέσµατα  του  "Copy"  ενώ  στις  στήλες  D -  F τα  αποτελέσµατα  του  "Copy with
dates".

Επικόλληση δεδοµένων

Ο  χρήστης  έχει  τη  δυνατότητα  να  επικολλήσει  δεδοµένα,  που  έχει  αντιγράψει  από
τον  Υδρογνώµωνα  ή  κάποιο  άλλο  αρχείο  (αρκεί  να  έχουν  την  κατάλληλη
µορφοποίηση) µε τρεις διαφορετικούς τρόπου:

1. Εdit→Paste,  είναι  ο  απλούστερος  και  πιο  διαδεδοµένος  τρόπος  επικόλλησης,  µε
τον  οποίο  τα  επιλεγµένα  δεδοµένα  επικολλούνται  στα  επιλεγµένα  κελιά.  Στην
περίπτωση που έχει επιλλεγεί ένα κελί, τα υπόλοιπα δεδοµένα επικολλούνται από
κάτω του αντικαθιστώντας το περιεχόµενο των υφιστάµενων κελιών.

1. Edit→Paste monthly table, χρησιµοποιείται για µηνιαία δεδοµένα τα οποία έχουν
αντιγραφεί  από  πίνακα  µηνιαίων  τιµών  (12  στήλες)  /  έτος,  τα  οποία  ο  χρήστης
επιθυµεί  να  επικολλήσει  σε  κάποια  χρονοσειρά.  Ο  χρήστης  επιλέγει  το  έτος  στο
οποίο  θα  επικολληθουν  τα  δεδοµένα  καθώς  κι  αν  πρόκειται  για  υδρολογικό  ή
ηµερολογιακό έτος.
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1. Edit→Paste  daily  table,  αντίστοιχα  µε  την  προηγούµενη  εντολή,  σε  αυτή  την
περίπτωση  τα  δεδοµένα  έχουν  την  µορφή  πίνακα  12  στηλών  (µήνες)  και  31
σειρών (µέρες). 

3.6 Φίλτρα - επισήµανση - σύντοµα αθροίσµατα

Τα  φίλτρα  όπως  και  η  επισήµανση  και  τα  σύντοµα  αθροίσµατα  είναι  απλά  εργαλεία
που διευκολύνουν τον χρήστη να βρει ακραίες ή σηµαιοθετηµένες τιµές, κλπ.

Η ενεργοποίηση των φίλτρων γίνεται µέσω του µενού View→Set Filter:

Ένα νέο παράθυρο ανοίγει όπου ο χρήστης θέτει το κριτήριο φιλτραρίσµατος:

Σύµφωνα µε το παραπάνω παράθυρο ο χρήστης θέτει κάποιο κριτίριο σχετικά µε τις
τιµές  της  χρονοσειράς  (µικρότερο  από  ή  µεγαλύτερο  από)  ή  µε  την  ύπαρξη  ή  µη
κενών  τιµών.  Εναλακτικά  ο  χρήστης  έχει  την  δυνατότητα  να  φιλτράρει  σύµφωνα  µε
τις σηµαίες που µπορεί να περιλαµβάνει κάποια εγγραφή:
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Αφού  τεθεί  κριτήριο  φιλτραρίσµατος,  η  λειτουργία  ενεργοποιείται  -  απενεργοποιείται
επιπρόσθετα µε χρήση του κουµπιού «Filter»:

Επισήµανση (Highlighting)
Μία  ακόµα  βοηθητική  λειτουργία  είναι  η  επισήµανση  µε  χρώµα  (highlighting).  Οι
επιλογές  επισήµανσης  βρίσκονται  κάτω  από  το  µενού  View→Calculations→
Highlight Mode:
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∆εν  είναι  πάντα  ορατές  όλες  οι  επιλογές  του  µενού.  Αυτό  εξαρτάται  αν  η  προβολή
των  χρονοσειρών  γίνται  σε  στήλες,  πίνακες  και  αν  εµφανίζονται  ή  όχι  τα  στατιστικά
στους πίνακες. Οι λειτουργίες είναι οι εξής:

• No highlighted cells: ∆εν γίνεται καµία επισήµανση

• Empty cells: Επισηµαίνονται τα άδεια κελιά

• Cells  with  any  flag  set:  Επισηµαίνονται  οι  εγγραφές  όπου  κάποια  σηµαία  είναι
ανοικτή

• Maximum: Επισηµαίνονται οι µέγιστες τιµές ανά στήλες

• Minimum: Οι ελάχιστες τιµές

• Maximum an minimum: Οι µέγιστες και οι ελάχιστες

• Large values: Οι µεγάλες τιµές όπως ορίζονται στα στατιστικά των στηλών (~99%
βάσει  της  κανονικής  κατανοµής  (άνω/κάτω  όριο  =  µ±3σ  όπου  µ  η  µέση  τιµή  του
δείγµατος και σ η τυπική απόκλιση).

• Small values: Οι µικρές τιµές

• Large and small values: Οι µεγάλες και οι µικρές τιµές

Σύντοµα αθροίσµατα (Quick sums)
Ο χρήστης έχει την δυνατότητα να «µαρκάρει» τιµές και στην συνέχεια να υπολογίσει
άθροισµα αυτών των τιµών, πλήθος µη κενών τιµών, µέση τιµή και µέγιστη/ελάχιστη
τιµή. Κάνοντας χρήση του µενού View→Quick sum:
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εµφανίζεται ένα παράθυρο που περιέχει τα σύντοµα αποτελέσµατα:

3.7 Σηµαιοθέτηση - προβολή σηµαιών

Κάθε  εγγραφή  χρονοσειράς  µπορεί  να  περιλαµβάνει  τιµή  (ή  κενό  -  έλλειψη)  καθώς
και ειδικές επισηµάνσεις που ονοµάζονται «Σηµαίες» (Flags). Σε µία εγγραφή µπορεί
να  περιλαµβάνεται  καµία,  µία  ή  και  πολλές  σηµαίες.  Η  σηµαία  επισηµαίνει  κάποιο
ιδιαίτερο  χαρακτηριστικό  κάποιας  τιµής,  π.χ.  η  τιµή  προέκυψε  από  συµπλήρωση.
Κάποιες  σηµαίες  αφορούν  προτωγείς  µετρήσεις  (π.χ.  ΧΙΟΝΙ  -  SNOW  κατά  την
µέτρηση βροχόπτωσης) ενώ κάποιες  άλλες  προκύπτουν  κατά  την  επεξεργασίας  (π.
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χ. τιµές που προέκυψαν από οµογενοποίηση).

Η  ενεργοποίηση  της  προβολής  των  σηµαιών  γίνεται  µε  χρήση  του  µενού  View→
Show flags:

Η  λειτουργικότητα  αυτή  αναπαράγεται  και  από  το  κουµπί  "Flags".  Μία  νέα  στήλη
εµφανίζεται δίπλα στα δεδοµένα της χρονοσειράς η οποία περιέχει τις σηµαίες κάθε
εγγραφής:

Οι  εγγραφές  µε  την  σηµαία  απεικονίζονται  κίτρινες  λόγω  ενεργοποίησης  της
λειτουργίας  επισήµανσης  (highlighting).  Η  στήλη  που  περιέχει  τις  σηµαίες  των
εγγραφών  µπορεί  να  τροποποιηθεί  άµεσα  από  τον  χρήστη  πληκτρολογόντας  π.χ.
την  λίστα  µε  τα  ονόµατα  σηµαιών.  Επιπλέον  δίνεται  η  δυνατότητα  ανταλαγής
πληροφοριών µε το clipboard / άλλα λογισµικά όπως το Microsoft Excel.

Η  τροποποίηση  των  σηµαιών  κάποιας  εγγραφής  γίνεται  ευκολότερα
χρησιµοποιώντας την λειτουργία του µενού Edit→Set flags...: ένα παράθυρο ανοίγει
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µε τις δυνατές σηµαίες που µπορεί να θέσει ο χρήστης:

Η ερµηνία των σηµαιών δίνεται στο παρακάτω πίνακα (βλ. και τεύχος θεωρητικής
τεκµηρίωσης):

Σηµαία
(αγγλικά)

Σύντοµη
µετάφραση

Χρήση σηµαίας

RANGE Εκτός ορίων Η τιµή είναι εκτός ορίων

SPATIAL Ασυνεπής
χωρικά

Η τιµή είναι ασυνεπής στο χώρο

TEMPORAL Ασυνεπής
χρονικά

Η τιµή είναι χρονικά ασυνεπής

INTERNAL Ασυνεπής
εσωτερικά

Η τιµή είναι εσωτερικά ασυνεπής

ESTIMATED Εκτιµηµένη Η τιµή είναι κατ' εκτίµηση

SUSPECT Ύποπτη Η τιµή είναι ύποπτη

SNOW Χιόνι Χιόνι κατά τη στιγµή της µέτρησης

ICE Πάγος Πάγος κατά τη στιγµή της µέτρησης

FROST Παγετός Παγετός κατά τη στιγµή της µέτρησης

DIVE Πληµµυρισµένος Σταθµός  πληµµυρισµένος  κατά  τη  στιγµή  της
µέτρησης

SPILL Υπερχείλιση Σταθµός  σε  κατάσταση  υπερχείλισης  κατά  τη  στιγµή
της µέτρησης

PUMP Άντληση Τιµή υπό άντληση (για γεωτρήσεις)

LOGOVERRUN,
LOGNOISY,
LOGOUTSIDE,
LOGRANGE 

- Σηµαίες του logger της Delta-T
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HOMOGEN Από
οµογενοποίηση

Η τιµή προέρχεται από οµογενοποίηση

INFILLING Από
συµπλήρωση

Η τιµή προέρχεται από συµπλήρωση

PENMAN Penman Η τιµή έχει υπολογιστεί µε τη µέθοδο Penman

DATEINSERT Εισηγµένη
ηµεροµηνία

Η  ηµεροµηνία  δεν  υπήρχε  στην  πρωτογενή
χρονοσειρά και δηµιουργήθηκε κατά τη µετατροπή σε
σταθερό χρονικό βήµα

INCONSISTENT
 

Ασυνεπής Η τιµή είναι ασυνεπής

AUTO Αυτόµατα Η τιµή έχει παραχθεί αυτόµατα

MISSING Ελλείψεις Η  τιµή  προέρχεται  από  χρονοσειρά  µικρότερου
χρονικού  βήµατος,  και  µερικές  τιµές  έλλειπαν,  οπότε
η εξαγωγή της τιµής (µε συνάθροιση, µέσο όρο, κλπ.)
έχει γίνει από τις υπόλοιπες

3.8 Χρήση µενού συντόµευσης (Popup menu)

Πατώντας  το  δεξί  κουµπί  του  ποντικιού,  πάνω  από  κάποια  εγγραφή  χρονοσειράς
εµφανίζεται το παρακάτω µενού συντόµευσης (popup menu):

Τις  λειτουργίες  αυτές  ο  χρήστης  µπορεί  να  τις  συναντήσει  σε  κάποια  από  τα  κύρια
µενού της φόρµας διαχείρισης χρονοσειρών:

• Copy, Copy with dates και Paste: επεξηγούνται στο υποκεφάλαιο: «Επεξεργασία
- Αντιγραφή - Επικόλληση»

• Insert  record...  και  Delete  selected  records:  επεξηγούνται  στο  υποκεφάλαιο:  «
Επεξεργασία - εισαγωγή νέων εγγραφών»
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• Set value..., set null: επεξηγούνται στο υποκεφάλαιο: «Απεικόνιση δεδοµένων και
επεξεργασία τιµών»

• Set flags...: επεξηγείται στο υποκεφάλαιο: «Σηµαιοθέτηση - προβολή σηµαιών»

• Quick sum: στο υποκεφάλαιο: «Φίλτρα - επισήµανση - σύντοµα αθροίσµατα»

• Time  series  properties...:  ιδιότητες  χρονοσειράς  όπως  περιγράφονται  στο
υποκεφάλαιο: «∆ηµιουργία νέας χρονοσειράς - προβολή ιδιοτήτων χρονοσειράς».





Μέρος

Ποιοτικός έλεγχος δεδοµένων
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4 Ποιοτικός έλεγχος δεδοµένων

Ο  έλεγχος  της  ποιότητας  των  δεδοµένων  περιλαµβάνει  τους  ελέγχους  που  γίνονται
στα  πρωτογενή  δεδοµένα,  έτσι  ώστε  να  εξακριβωθεί  και  στη  συνέχεια  να
διασφαλιστεί  η  ακεραιότητα  τους.  Οι  έλεγχοι  που  µπορούν  να  πραγµατοποιηθούν
είναι  αυτοί  των  ακραίων  τιµών,  της  χωρικής  και  χρονικής  συνέπειας,  καθώς  και
έλεγχος σταθερότητας βήµατος, όπως και των κενών τιµών.

4.1 Έλεγχος ακραίων τιµών

Επιλογή από το βασικό µενού Series→Range check.

2. Συµπλήρωση  του  άνω  και  κάτω  κατωθλιού  στη  φόρµα  που  ακολουθεί.  Ο
χρήστης µπορεί να επιλέξει την αυτόµατη ρύθµιση (Auto) οπότε τα κατώθλια
ρυθµίζονται σύµφωνα µε την κανονική κατανοµή και το ποσοστό βεβαιότητας
(Confidence  level)  (βλ.  τεύχος  θεωρητικής  τεκµηρίωσης).  Τέλος  ο  χρήστης
επιλέγει την σηµαία µε την οποία σηµαιοθετούνται οι ακραίες τιµές (Mark out
of range values with flag).

3. Γίνεται επισήµανση των ακραίων τιµών µε την σηµαία που επέλεξε ο χρήστης.
Ο χρήστης µπορεί να εµφανίσει τις σηµαίες (π.χ. µέσω του κουµπιού Flags),
να  εφαρµόσει  φιλτράρισµα  εγγραφών,  κλπ.  Η  επεξεργασία  γίνεται  επί  της  
ενεργής χρονοσειράς.
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4.2 Έλεγχος χρονικής συνέπειας

Από το βασικό µενού επιλογή Series→Time consistency check.

2. Συµπλήρωση της τιµής Triger value στη φόρµα που ακολουθεί. Αυτή είναι  η
ελάχιστη  τιµή  βάσει  της  οποίας  συγκρίνονται  δύο  διαδοχικές  εγγραφές.  Αν
γίνει  υπέρβαση  της  τιµής  τότε  η  επόµενη  τιµή  θεωρείται  ασυνεπής  και
σηµαιοθετείται  µε  την  σηµαία  που  καθορίζει  ο  χρήστης  στο  παρακάτω
παράθυρο (Mark time inconsistent values with flag:):

3. Το  αποτέλεσµα  είναι  να  επισηµαίνονται  οι  διαδοχικές  τιµές  που  διαφέρουν
περισσότερο  από  την  τιµή  που  τέθηκε  στο  Triger  value.  Η  επεξεργασία
γίνεται επί της ενεργής χρονοσειράς.
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Ο  χρήστης  µπορεί  να  δει  τις  ασυνεπείς  τιµές  εµφανίζοντας  τις  σηµαίες  (π.χ.  µε  το
κουµπί Flags).



Μέρος

Βασική επεξεργασία χρονοσειρών
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5 Βασική επεξεργασία χρονοσειρών

Η  βασική  επεξεργασία  των  χρονοσειρών  περιλαµβάνει  την  άρση  χρονικών
µετατοπίσεων  στις  ακανόνιστες  (πρωτογενείς)  χρονοσειρές  ώστε  να  αποκτήσουν
κανονικό  χρονικό  βήµα,  τη  συνάθροισης  των  τιµών  των  χρονοσειρών  ώστε  να
προκύψουν  χρονοσειρές  µεγαλύτερου  χρονικού  βήµατος  καθώς  και  το  γραµµικός
συνδιασµός (γραµµικές πράξεις).
Με  αυτούς  τους  χειρισµούς  προκύπτουν  επεξεργασµένες  χρονοσειρές  µεταβλητών
όπως  η  βροχόπτωση,  η  στάθµη,  η  θερµοκρασία,  κ.α.  ακόµη  και  σε  µεγάλα  χρονικά
βήµατα όπως το µηνιαίο και το ετήσιο.

5.1 Εργαλείο πολλαπλής επιλογής χρονοσειρών
Μία σειρά επεξεργασιών που διαθέτει ο Υδρογνώµων γίνονται µε στοιχεία εισόδου
παραπάνω από µία χρονοσειρές. Για τον σκοπό αυτό έχει αναπτυχθεί µία ειδική
φόρµα όπου ο χρήστης καθορίζει ποιες χρονοσειρές θα χρησιµοποιηθούν σε κάθε
επεξεργασία από τις χρονοσειρές που είναι ανοικτές.

Η µορφή της φόρµας απεικονίζεται στη συνέχεια:

Η φόρµα έχει δύο περιοχές. Στην αριστερή περιοχή εµφανίζονται οι διαθέσιµες
χρονοσειρές που έχουν ανοίξει στον Υδρογνώµονα. Στην δεξιά περιοχή εµφανίζονται
κατηγορίες στις οποίες γίνεται αντιστοίχηση χρονοσειρών από την λίστα αριστερά.

Έτσι αν ο χρήστης «πιάσει» και «σύρει» (drag’n drop) χρονοσειρές από την αριστερή
περιοχή στην δεξιά, θα δηµιουργηθεί µία εικόνα σαν την παρακάτω:
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Ο χρήστης µπορεί να «σύρει» χρονοσειρές και µεταξύ των κατηγοριών. Επιπλέον
µπορεί να απορρίψει χρονοσειρές «σέρνοντας» τις στο καλάθι αχρήστων.

Πατώντας το κουµπί “OK” γίνεται η διενέργεια της επεξεργασίας ενώ µε “Cancel”
γίνεται ακύρωση και καµιά επεξεργασία δεν γίνεται. Με το κουµπί “Info” εµφανίζεται
κάθε φορά µία λίστα µε την επεξήγηση των κατηγοριών.

Οι κατηγορίες σηµαίνονται ως “unique” στην περίπτωση που απαιτείται (έως) µία
χρονοσειρά ανά κατηγορία και ως “unlimited” στην περίπτωση που µπορούν να
καθοριστούν απεριόριστες χρονοσειρές στην κατηγορία. Ανάλογα την επεξεργασία,
µπορεί σε κάποια κατηγορία να υπάρχει επιπλέον υποχρεωτικός καθορισµός
χρονοσειράς (π.χ. για τον υπολογισµό εξατµοδιαπνοής, είναι υποχρεωτικός ο
καθορισµός χρονοσειράς θερµοκρασίας).

Γενικά οι επεξεργασίες που χρησιµοποιούν το συγκεκριµένο εργαλείο είναι: Η
παλινδρόµηση χρονοσειρών, υπολογισµός εξάτµισης – εξατµοδιαπνοής, ο Ζυγός,
χωρική ολοκλήρωση χρονοσειρών, καµπύλες και παρεµβολές, διπλή αθροιστική
καµπύλη. 

5.2 Κανονικοποίηση χρονικού βήµατος

Η επεξεργασία γίνεται επί της  ενεργής χρονοσειράς.

1. Από το βασικό µενού επιλογή Series→Regularize Step.
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2. Στην  φόρµα  που  ακολουθεί,  συµπληρώνεται  η  χρονική  µετατόπιση  (offset  in
minutes), ο τύπος της µεταβλητής και η ένδειξη της σηµαίας για τις νέες εγγραφές
που  προκύπτουν  αν  υπάρχουν  κενά  στην  ακανόνιστη  χρονοσειρά.  Η  διαδικασία
ολοκληρώνεται πατώντας το κουµπί ΟΚ.

Ο χρήστης µπορεί να επιλέξει µεταξύ:

• Normal instantaneous: Οι µεταβλητές είναι στιγµιαίες όπως θερµοκρασία, σχετική
υγρασία, στάθµη, κλπ

• Vector  instantaneous:  Οι  µεταβλητές  είναι  σγιµαιάιες  µεν  αλλά  αφορούν
διευθύνσεις σε µοίρες (π.χ. διεύθυνση ανέµου)

• Cumulative:  Οι  µεταβλητές  είναι  αθροιστικές  όπως  ύψος  βροχόπτωσης,  διάρκεια
ηλιοφάνειας, απορροή, κλπ. Ο χρήστης καθορίζει αν οι µετρήσεις είναι για κάποια
σταθερή  χρονική  περίοδο  (each  measurement  is  for  a  period  equal  to  the  time
step)  ή  αφορούν  µία  περίοδο  που  ξεκινάει  από  την  προηγούµενη  µέτρηση.  Στις
ακανόνιστες χρονοσειρές συνήθως ισχύει η δεύτερη συνθήκη.

• Change  time:  Γίνεται  τροποποίηση  των  χρονικών  στιγµών  µέτρησης  ώστε  η
χρονοσειρά να αποκτήσει κανονικό χρονικό βήµα.

Το  offset  τοποθετείται  π.χ.  στην  τιµή  480  λεπτά,  προκειµένου  για  µία  χρονοσειρά
ηµερήσιου χρονικού βήµατος όπου οι µετρήσεις είναι κάθε µέρα στις 08:00 το πρωί,
κλπ
Προκειµένου να εκτελεστεί η διεργασία, ο χρήστης πρέπει να αλλάξει χειροκίνητα το
χρονικό  βήµα  της  ακανόνιστης  χρονοσειράς  µέσω  του  παραθύρου  ιδιοτήτων  της
χρονοσειράς.
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Αφού  εκτελεστεί  η  επεξεργασία,  η  χρονοσειρά  αποκτά  επιπλέον  την  ιδιότητα  Time
step  strict  (Αυστηρό  χρονικό  βήµα).  Αυτή  είναι  µία  απαραίτητη  συνθήκη  για  να
υλοποιηθούν κάποιες από τις επεξεργασίες χρονοσειρών όπως η συνάθροιση.
Η επεξεργασία  της κανονικοποίησης όπως γίνεται  στο παρόν τµήµα του  λογισµικού
έχει  τον  περιορισµό  πως  οι  µετρήσεις  πρέπει  να  είναι  ti±25%d  όπου  d  το  χρονικό
βήµα. Για παράδειγµα σε µία χρονοσειρά  δεκάλεπτου  χρονικού βήµατος µε  offset 0
(οπότε  οι  µετρήσεις  είναι  00:00,  00:10,  00:20,  ...)  οι  µετρήσεις  µεταξύ  00:02:30  και
00:07:30, ... αγνοούνται. Σε αυτές τις περιπτώσεις λύση µπορεί να δώσει η δεύτερη
µεθοδολογία µετατροπής του βήµατος των χρονοσειρών σε κανονικό.

5.3 Μετατροπή του βήµατος των χρονοσειρών σε κανονικό (Irregular
to strict)

Η επεξεργασία γίνεται επί της  ενεργής χρονοσειράς.

1. Επιλογή από το βασικό µενού Series→Irregular to strict.

2. Στην  φόρµα  που  ακολουθεί,  συµπληρώνεται  το  τελικό  χρονικό  βήµα,  η
χρονική µετατόπιση και ο τύπος της µεταβλητής.

Ο  αλγόριθµος  που  εφαρµόζεται  σε  αυτό  το  τµήµα  του  λογισµικού  είναι
«ανθεκτικότερος»  από  τον  αντίστοιχο  που  χρησιµοποιείται  στην  «κανονικοποίηση
του  χρονικού  βήµατος» αλλά  µπορεί  να  είναι  ασταθής  σε  κάποιες  περιπτώσεις  (βλ.
τεύχος  θεωρητικής  τεκµηρίωσης).  Γενικά  προτείνεται  να  χρησιµοποιείται  η
κανονικοποίησης όπως περιγράφεται στο προηγούµενο κεφάλαιο και αν δεν µπορεί
να δοθεί λύση να χρησιµοποιείται ο παρόν αλγόριθµος.
Σύµφωνα  µε  τον  παρόν  αλγόριθµο,  µπορεί  να  εφαρµοστεί  σε  χρονοσειρές  µε
πλήρως  ακανόνιστο  βήµα,  χωρίς  περιορισµούς  και  σε  χρονικά  βήµατα  µικρότερα
από  το  ελάχιστο  που  παρέχεται  από  το  λογισµικό  (δεκάλεπτο).  Έτσι  είναι  δυνατή  η
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εφαρµογή  σε  χρονοσειρά  µετρήσεων  π.χ.  δύο  λεπτών  ώστε  να  προκύψει
επεξεργασµένο δεκάλεπτο.
Ο  χρήστης  επιλέγει  Instantaneous  (στιγµιαία)  για  στιγµιαίες  µεταβλητές  όπως
στάθµη,  θερµοκρασία  και  σχετική  υγρασία  ή  Cumulative  (αθροιστική)  για
αθροιστικές  µεταβλητές  όπως  ύψος  βροχόπτωσης,  ύψος  απορροής  και  διάρκεια
ηλιοφάνειας.
Ενδέχεται να προστεθούν νέες δυνατότητες στην λειτουργία µετατροπής του βήµατος
σε  κανονικό,  όπως  µεταβλητές  µεγίστων  /  ελαχίστων  και  διανυσµατικές  (διεύθυνση
ανέµου).

5.4 Συνάθροιση  χρονοσειρών

Η επεξεργασία γίνεται επί της  ενεργής χρονοσειράς.
Οι  λειτουργίες  συνάθροισης  αφορούν  την  παραγωγή  χρονοσειρών  µε  µεγαλύτερο
χρονικό βήµα από την αρχική χρονοσειρά, π.χ. δεκάλεπτη → ωριαία → ηµερήσια →
µηνιαία → ετήσια. 

1. Επιλογή από το βασικό µενού Series→Aggregation.

2. Στην  φόρµα  που  ακολουθεί,  καθορίζεται  η  µέθοδος  συνάθροισης
(aggregation method) καθώς και το πλήθος των ελλιπουσών τιµών (Number
of missing values to accept).

Οι επιλογές της µεθόδου συνάθροισης είναι:

• Sum: Άθροισµα των τιµών

• Average:  Μέση  τιµή  των  τιµών  εντός  της  περιόδου  του  µεγαλύτερου  χρονικού
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βήµατος

• Maximum: Μέγιστη τιµή εντός της περιόδου του µεγαλύτερου χρονικού βήµατος

• Minimum: Ελάχιστη τιµή

• Vector: Όπως το Average αλλά για διανυσµατικές τιµές (διευθύσεως σε µοίρες)

• First Instant.: Σε στιγµιαίες µεταβλητές, επιλέγεται η πρώτη τιµή από το µικρότερο
χρονικό βήµα. Μπορεί να παραχθεί για παράδειγµα µια µηνιαία χρονοσειρά µε την
πρώτη τιµή κάθε µήνα από την ηµερήσια στάθµη ενός ταµιευτήρα.

3. Το  αποτέλεσµα  είναι  δύο  νέες  χρονοσειρές  που  απεικονίζονται  ως
διαφορετικές  στήλες,  όπως  φαίνεται  στην  εικόνα  που  ακολουθεί.  Η  πρώτη
χρονοσειρά είναι το αποτέλεσµα της συνάθροισης, δηλαδή κάποιος αριθµός ή
κενό  ανάλογα  µε  τις  ελλείψεις  της  αρχικής  χρονοσειράς.  Η  δεύτερη
χρονοσειρά (στήλη) είναι ένας ακέραιος αριθµός µε τον αριθµό ελλείψεων για
την χρονική περίοδο συνάθροισης.

Το  µέγιστο  πλήθος  των  ελλείψεων  (Number  of  missing  values  to  accept)  είναι
προρυθµισµένο  στην  τιµή  µηδέν  (0),  το  οποίο  σηµαίνει  πως  δεν  γίνεται  αποδεκτή
καµία  έλλειψη.  Ο  χρήστης  µπορεί  να  τροποποιήσει  αυτήν  την  τιµή  ανάλογα  µε  την
διαθεσιµότητα  των  δεδοµένων  και  την  κρισιµότητα  των  ελλείψεων  (π.χ.  σε  ύψη
βροχόπτωσης,  συνήθως,  οι  ελλείψεις  δεν  είναι  αποδεκτές).  Στην  περίπτωση
υπέρβασης  του  µέγιστου  επιτρεπόµενου  αριθµού  ελλείψεων,  στην  χρονική  περίοδο
τοποθετείται  κενή  τιµή.  Αν  υπολογίζεται  τιµή  (πλήθος  ελλείψεων  <  max
επιτρεπόµενο) αίρεται η κατάλληλη σηµαία που καθορίζεται στο πεδίο "For records
derived from incomplete source, raise flag:".
Το time offset πρέπει να τίθεται σε µη µηδενική τιµή όταν η χρονοσειρά έχει σταθερή
χρονική  µετατόπιση,  π.χ.  480  λεπτά  για  ηµερήσια  χρονοσειρά  όπου  οι  µετρήσεις
γίνονται καθηµερινά στις 08:00 το πρωί.
Όταν  πρόκειται  να  παραχθεί  ετήσια  χρονοσειρά  ο  χρήστης  µπορεί  να  επιλέξει
συνάθροιση  στο  υδρολογικό  έτος  (Use  hydrological  year).  Επιπλέον  µπορεί  να
επιλέξει εποχική συνάθροιση που θα περιλαµβάνει κάποιους µήνες του χρόνου (π.χ.
Νοέµβριο έως Μάρτιο) (Seasonal aggregation).
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5.5 Γραµµικές πράξεις µεταξύ των χρονοσειρών

Οι  γραµµικές  πράξεις  γίνονται  µεταξύ  των  χρονοσειρών  που  απεικονίζονται  σε  ένα
πλέγµα.

1. Επιλογή από το βασικό µενού Series→Linear Combinations.

2. Στην  φόρµα  που  ακολουθεί,  συµπλήρωση  του  σταθερού  όρου  (Constant
Coefficient) και των  συντελεστών για κάθε χρονοσειρά από τον χρήστη.

3. Ολοκλήρωση της διαδικασίας πατώντας το ΟΚ.

4. Το  αποτέλεσµα  είναι  µια  νέα  στήλη,  όπως  φαίνεται  στην  παρακάτω  εικόνα
που περιέχει τον γραµµικό συνδιασµό.
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5.6 Επιµερισµός χρονικού βήµατος

Η επεξεργασία γίνεται επί της  ενεργής χρονοσειράς.
Οι λειτουργία επιµερισµού του χρονικού βήµατος αφορά την παραγωγή χρονοσειρών
µε  µικρότερο  χρονικό  βήµα  από  την  αρχική  χρονοσειρά,  π.χ.  η  µετατροπή  µίας
ωριαίας  χρονοσειράς  σε  ηµερήσια.   Ο  επιµερισµός  γίνεται  κάθε  φορά  στο  αµέσως
µικρότερο  χρονικό  βήµα:  ετήσιο  →  µηνιαίο  →  ηµερήσιο  →  ωριαίο  →  δεκάλεπτο  →
πεντάλεπτο.

1. Επιλογή από το βασικό µενού Series→Disaggregation.

2.  Στην  φόρµα  που  ακολουθεί,  καθορίζεται  η  µέθοδος  επιµερισµού
(disaggregation method)
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Οι επιλογές της µεθόδου επιµερισµού είναι:

Cumulative (constant disaggregated values): Η χρονοσειρά που προκύπτει
από τον επιµερισµό, αν συναθροιστεί δίνει την αρχική  χρονοσειρά  και  οι  νέες
τιµές που προκύπτουν είναι σταθερές για κάθε χρονικό βήµα.

Cumulative (random disaggregated values): Η χρονοσειρά που προκύπτει
από  τον  επιµερισµό,  αν  συναθροιστεί  δίνει  την  αρχική  χρονοσειρά,  αλλά  οι
νέες  τιµές  που  προκύπτουν  είναι  ψευδοτυχαίες  για  κάθε  χρονικό  βήµα  και
ακολουθπυν µια κατανοµή που ορίζει ο χρήστης (οµοιόµορφη, εκθετική, κλπ).

     Average  (constant  disaggregated  values):  Η  χρονοσειρά  που  προκύπτει
από τον επιµερισµό, αν ολοκληρωθεί µε την επεξεργασία της µέσης τιµής δίνει
την  αρχική  χρονοσειρά  και  οι  νέες  τιµές  που  προκύπτουν  είναι  σταθερές  για
κάθε χρονικό βήµα.

   Average  (random  disaggregated  values):  Η  χρονοσειρά  που  προκύπτει
από τον επιµερισµό, αν ολοκληρωθεί µε την επεξεργασία της µέσης τιµής δίνει
την  αρχική  χρονοσειρά,  αλλά  οι  νέες  τιµές  που  προκύπτουν  είναι
ψευδοτυχαίες για κάθε χρονικό βήµα και ακολουθπυν µια κατανοµή που ορίζει
ο χρήστης (οµοιόµορφη, εκθετική, κλπ).

5.7 Σύνθετες πράξεις

Οι σύνθετες πράξεις διαφέρουν από τις γραµµικές πράξεις στο ότι χρησιµοποιούνται
συναρτήσεις  οι  οποίες  ορίζονται  από  το  χρήστη,  όπως  εκείνος  θα  τις  διατύπωνε  µε
µαθηµατική γλώσσα π.χ. sin(x1+0.4*(3-x2*x3^x4)).
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Στη  φόρµα  που  ανοίγει,  ο  χρήστης  µπορεί  να  δει  την  ονοµασία  των  υπάρχουσων
χρονοσειρών  (π.χ.  x1,  x2  και  x3)  και  τα  διαθέσιµα  σύµβολα  της  µαθηµατικής
γλώσσας. 

5.8 ∆ιπλή αθροιστική καµπύλη

Η  διπλή  αθροιστική  καµπύλη  είναι  µία  ηµιεµπειρική  µέθοδος  για  έλεγχο  και
αποκατάσταση της οµοιογένειας χρονοσειρών βροχόπτωσης (βλ. τεύχος θεωρητικής
τεκµηρίωσης). Η εφαρµογή της µεθοδολογίας γίνεται ως εξής:

1. Φόρτωση χρονοσειρών:
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Οι χρονοσειρές που χρησιµοπιούνται στον έλεγχο πρέπει να έχουν µηνιαίο ή ετήσιο
χρονικό  βήµα  (προτείνεται  το  ετήσιο).  Μία  εκ'των  δύο  χρονοσειρών  είναι  η
χρονοσειρά  αναφοράς  ενώ  η  άλλη  είναι  η  χρονοσειρά  ελέγχου.  Στο  παραπάνω
σχήµα  η  5+ (ετήσια)  είναι  η  χρονοσειρά  αναφοράς  ενώ  η  4+ (ετήσια)  η  χρονοσειρά
ελέγχου.  Η  χρονοσειρά  4  (µηνιαία)  είναι  η  αρχική  χρονοσειρά  από  την  οποία
προέκυψε η ετήσια µε την λειτουργία συνάθροισης. Ο χρήστης µπορεί να καθορίσει
χρονοσειρές  προς  αναγωγή  µικρότερων  χρονικών  βηµάτων  από  τις  οποίες
προέκυψε τελικά η χρονοσειρά ελέγχου.

2. Επιλογή του menu Hydrology→Double mass curve...
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3. Ανοίγει  µία  φόρµα  που  παρουσιάζει  τις  διαθέσιµες  χρονοσειρές  (available
timeseries) και τις επιλογές που υπάρχουν για αυτές (timeseries selections)
. Ο χρήστης µεταφέρει τις διαθέσιµες χρονοσειρές «τραβώντας» τις στο δεξιό
πάνελ.

Τα  πεδία  Reference  timeseries  (χρονοσειρά  αναφοράς)  καθώς  και  Tested
timeseries (χρονοσειρά ελέγχου) πρέπει να συµπληρωθούν υποχρεωτικά µε µία και
µόνο  χρονοσειρά  από  αυτές  που  απεικονίζονται  στην  αριστερή  λίστα.  Στο  πεδίο
Reduced timeseries  (χρονοσειρές  αναγωγής),  ο  χρήστης  µπορεί  να  συµπληρώσει
από µία έως πολλές χρονοσειρές οι οποίες θα αναχθούν.

4. Kλικ στο κουµπί Info για να εµφανιστουν οι περιγραφές των χρονοσειρών που
απαιτούνται  για  τους  υπολογισµούς  και  κλείσιµο  της  φόρµας  πατώντας  το
κουµπί ΟΚ:

5. Με  το  OK  στην  φόρµα  της  επιλογής  χρονοσειρών,  ανοίγει  η  τελική  φόρµα
επεξεργασίας της διπλής αθροιστικής καµπύλης:
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6. Οι  λειτουργίες  επιτυγχάνονται  µε  τα  κουµπιά  της  µπάρας.  Τελικά  ο  χρήστης
αποδέχεται  την  λύση  πατώντας  ΟΚ  ή  αναιρεί  µε  Cancel.  Η  περιγραφή  των
λειτουργιών µε την σειρά που εµφανίζονται στα κουµπιά είναι:

• Undo - Αναίρεση προηγούµενης ενέργειας

• Redο - Αναίρεση της αναίρεσης

• Μαρκάρισµα  σηµείου  ως  σηµείο  θλάσης.  Τα  σηµεία  θλάσης  µπορούν  να  είναι
πάνω του ενός

• Αυτόµατο µαρκάρισµα σηµείου θλάσης.

• Μαρκάρισµα σηµείου ασυνέχειας

• Αυτόµατο µαρκάρισµα σηµείου ασυνέχειας

• Μετακίνηση επιλεχθέντος σηµείου αριστερά

• Μετακίνηση επιλεχθέντος σηµείου δεξιά

• Αποδοχή ενέργειας

• Ακύρωση ενέργειας

• Αναστροφή  της  διπλής  αθροιστικής  καµπύλης  (ως  προς  τον  χρόνο).  Αυτή  η
λειτουργεία µπορεί να διευκολύνει τον εντοπισµό πολλαπλών θλάσεων.

Το  αποτέλεσµα  του  αυτούµατου  µαρκαρίσµατος  του  σηµείου  θλάσης  στην
παραπάνω διπλή αθροιστική καµπύλη απεικονίζεται στο παρακάτω σχήµα:
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Πατώντας τελικά το κουµπί v γίνεται η τελική αναγωγή:

Τέλος µε το κουµπί OK τα τελικά αποτελέσµατα µε την µορφή χρονοσειρών:



Υ∆ΡΟΓΝΩΜΩΝ56

(c) 2009 Εθνικό Μετσόβιο Πολυτεχνείο



Μέρος

Υδρολογική επεξεργασία δεδοµένων
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6 Υδρολογική επεξεργασία δεδοµένων

Ο «Υδρογνώµονας» µεταξύ άλλων υλοποιεί τις παρακάτω λειτουργίες επεξεργασίας
υδρολογικών δεδοµένων:

• Έλεγχος  και  αποκατάσταση  οµοιογένειας  µε  την  µέθοδο  της  διπλής
αθροιστικής καµπύλης. Ο έλεγχος γίνεται χρησιµοποιοώντας µηνιαία ή ετήσια
δεδοµένα βροχοπτώσεων, η αποκατάσταση µπορεί να γίνει και στα µικρότερα
χρονικά βήµατα από τα οποία προέκυψαν τα µηνιαία ή τα ετήσια.

• Υπολογισµοί  εξάτµισης  και  δυνητικής  εξατµοδιαπνοής  µε  διάφορες
µεθοδολογίες όπως, Penman, Penman - Monteith, κ.α.

• Παρεµβολές  χρονοσειρών  σε  καµπύλες  -  καµπύλες  στάθµης-παροχής  /
παροχής-στερεοπαροχής  .  Ο  χρήστης  µέσω  αυτής  της  δυνατότητας
δηµιουργεί  χρονοσειρές  που  έχουν  προκύψει  από  την  παρεµβολή  κάποιων
αρχικών χρονοσειρών πάνω σε καµπύλες. Οι καµπύλες αυτές µπορεί να είναι
καµπύλες στάθµης - παροχής υδατορεύµατος, στάθµης - επιφάνειεας - όγκου
ταµιευτήρα,  κ.α.  Επιπλέον,  δίνεται  η  δυνατότητα  κατασκευής  καµπυλών
στάθµης  -  παροχής  και  παροχής-στερεοπαροχής  από  δεδοµένα
υδροµετρήσεων.

• Παλινδρόµηση  -  Συµπλήρωση  ελλειπουσών  τιµών  χρονοσειρών.  Παρέχονται
δυνατότητες  απλής  και  πολλαπλής  γραµµικής  παλινδρόµησης  µεταξύ
χρονοσειρών.  Στην  συνέχεια  τα  αποτελέσµατα  της  παλινδρόµησης
αξιοποιούνται για την συµπλήρωση των ελλείψεων.

• Αδροµερής  προσοµοίωση  υδρολογικών  διεργασιών  λεκάνης  απορροής
(Ζυγός)  µε  δυνατότητες  ρύθµισης.  Ο  χρήστης  παρέχει  χρονοσειρές
βροχόπτωσης,  δυνητικής  εξατµοδιαπνοής,  άντλησης  από  τον  υπόγειο
υδροφορέα.  Το  λογισµικό  προσοµοιώνει  τις  επιφανειακές  και  τις  υπόγειες
υδρολογικές  διεργασίες  υπολογίζοντας  τελικά  την  απορροή.  Παρέχεται
επιπλέον  δυνατότητα  ρύθµισης  του  µοντέλου  εφόσον  τροφοδοτηθεί  µε
µετρηµένη απορροή στην έξοδο της λεκάνης.

• Καταχώρηση  υδροµετρήσεων  -  Κατάρτιση  χρονοσειράς  παροχών  από
υδροµετρήσεις.  Ο  χρήστης  έχει  τη  δυνατότητα  καταχώρησης  στοιχείων
υδροµετρήσεων σαν υδατορεύµατα και στη συνέχεια τη συρραφή τους σε ένα
 αρχείο  το  οποίο  µπορεί  στην  συνέχεια  να  καταχωρηθεί  σε  κάποια  βάση
δεδοµένων.  Το  αρχείο  που  θα  δηµιουργηθεί  θα  περιέχει  στοιχεία  διατοµών,
σταθµηµετρήσεων  καθώς  και  υδροµετρήσεων  σε  διαφορετικά  βάθη,  µε
διάφορες µεθόδους. Στην συνέχεια ο χρήστης µπορεί να αξιοποιήσει αυτά τα
δεδοµένα  για  τον  αυτοµατοποιηµένο  υπολογισµών  των  µέσων  ταχυτήτων  ή  /
και  των  παροχών  καθώς  και  για  την  εξαγωγή  αυτόνοµων  χρονοσειρών
στάθµης – παροχής. 

6.1 Υπολογισµός εξάτµισης και δυνητικής εξατµοδιαπνοής

Η  εξάτµιση  ή  η  δυνητική  εξατµοδιαπνοή  µπορεί  να  υπολογιστεί  µε  διάφορες
µεθοδολογίες  σύµφωνα  µε  τις  απαιτήσεις  του  χρήστη  καθώς  και  την  διαθεσιµότητα
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των δεδοµένων.
Οι  χρονοσειρές  που  θα  χρησιµοποιηθούν  στους  υπολογισµούς  ανοίγονται  στο
πλέγµα των χρονοσειρών. Για τις χρονοσειρές πρέπει να ισχύουν τα εξής:

• Να έχουν το ίδιο χρονικό βήµα το οποίο πρέπει να είναι µηνιαίο κατά βάση ή
και ηµερήσιο (για τις µεθοδολογίες Penman και παραµετρική).

• Υποχρεωτικά  πρέπει  να  παρέχεται  χρονοσειρά  θερµοκρασίας  η  οποία
αξιοποιείται  από  όλους  τους  τρόπους  υπολογισµού.  Ειδικά  για  τις
µεθοδολογίες Penman και Penman - Monteith πρέπει να παρέχονται επιπλέον
χρονοσειρές  σχετικής  υγρασίας  (%),  ταχύτητας  ανέµου  (m/s)  καθώς  και
ακτινοβολίας ή διάρκειας ηλιοφάνειας σε λεπτά ή ποσοστού ηλιοφάνειας (%).

• Αν πρόκειται να προσαρµοστεί το εµπειρικό µοντέλο, πρέπει εκτός των άλλων
να  παρέχεται  µία  χρονοσειρά  εξάτµισης  η  οποία  να  έχει  υπολογιστεί  µε
Penman  ή  Penman  -  Monteith  ή  να  προέρχεται  από  κάποια  αξιόπιστη
µέτρηση.

Για να γίνει ο υπολογισµός της εξατµοδιαπνοής:

1. Από το βασικό µενού επιλογή Hydrology→Evapotraspiration.

2. Ανοίγει  µία  φόρµα  που  παρουσιάζει  τις  διαθέσιµες  χρονοσειρές  (available
timeseries) και τις επιλογές που υπάρχουν για αυτές (timeseries selections)
. Ο χρήστης µεταφέρει τις διαθέσιµες χρονοσειρές «τραβώντας» τις στο δεξιό
πάνελ.  Μπορεί  να  καθοριστεί  µέχρι  µία  χρονοσειρά  σε  κάθε  κατηγορία  στο
πάνελ δεξιά.
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3. Κλικ στο κουµπί Info για να εµφανιστουν οι περιγραφές των χρονοσειρών που
απαιτούνται  για  τους  υπολογισµούς  και  κλείσιµο  της  φόρµας  πατώντας  το
κουµπί ΟΚ.

4. Ανοίγει  µια  φόρµα  υπολογισµών  όπου  ανάλογα  µε  τη  µέθοδο  υπολογισµού
εισάγονται  τιµές  για  τις  παραµέτρους  Γεωγραφικό  πλάτος  (Latitude),
υψόµετρο  (Altitude),  λευκάδεια  (Albedo)  και  παράµετροι  υπολογισµού  του
ύψους  εξάτµισης  σύµφωνα  µε  τη  µέθοδο  του  Penman  (Ae,  aL,  As,  Be,  Bl,
Bs).  Με  την  επιλογή  default  χρησιµοποιούνται  οι  βιβλιογραφικές  τιµές  των
παραµέτρων.  Αντίστοιχες  παράµετροι  πρέπει  να  εισαχθούν  όταν
χρησιµοποιούνται οι υπόλοιπες µεθοδολογίες (π.χ. Thornthwaite). Επίσης στη
φόρµα  αυτή  καθορίζεται  ο  τύπος  των  δεδοµένων  της  χρονοσειράς
ηλιοφάνειας  (λεπτά,  ποσοστό  ή  ποσότητα  ακτινοβολίας)  καθώς  και  αν  η
ηµέρα  που  χρησιµοποιείται  είναι  µια  αντιπροσωπευτική  ηµέρα  ή  η  µεσαία
ηµέρα  του µήνα. Ειδικά  για την παραµετρική µεθοδολογία, ο χρήστης  µπορεί
να  κάνει  βέλτιστη  προσαρµογή  των  παραµέτρων  a,b  και  c  πατώντας  το
κουµπι Calc Params, εφόσον παρέχει υπολογισµένη χρονοσειρά εξατµισης /
εξατµοδιαπνοής για το καλιµπράρισµα.
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5. Ολοκλήρωση  της  διαδικασίας  πατώντας  το  κουµπί  ΟΚ.  Το  αποτέλεσµα  είναι
να εµφανιστεί µια νέα στήλη που παρουσιάζει το ύψος της εξατµοδιαπνοής σε
mm.
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6.2 Παρεµβολές - καµπύλες στάθµης-παροχής /
παροχής-στερεοπαροχής

Ο  «Υδρογνώµων» χρησιµοποιεί  ένα  ενιαίο  γραφικό  περιβάλλον  για  την  παρεµβολή
των  τιµών  των  χρονοσειρών  πάνω  σε  καµπύλες.  Τυπικά  προβλήµατα  αυτής  της
µορφής  είναι  ο  υπολογισµός  χρονοσειράς  παροχής  από  χρονοσειρές  µέτρησης
στάθµης  και  εφαρµογή  σε  καµπύλες  στάθµης  -  παροχής.  Συγκεκριµένα  οι  τύποι
υπολογισµών είναι οι παρακάτω:

• Υπολογισµός παροχής από στάθµη µε χρήση καµπυλών στάθµης - παροχής

• Υπολογισµός  επιφάνειας  και  όγκου  ταµιευτήρα  µε  χρήση  καµπυλών  στάθµης  -
επιφάνειας, αποθηκευτικότητας

• Υπολογισµός υπόγειων διαφυγών σε ταµιευτήρα

• Υπολογισµός υπερχειλίσεων µε χρήση καµπύλης στάθµης - παροχής υπερχειλιστή
φράγµατος

• Υπολογισµός  στερεοπαροχής  από  στάθµη  µε  χρήση  καµπυλών  παροχής  -
στερεοπαροχής.

1. Ο  χρήστης  φορτώνει  χρονοσειρές.  Στο  συγκεκριµένο  παράδειγµα
φορτώνονται  µετρήσεις  στάθµης  από  σταθµήµετρο  και  σταθµηγράφο,  καθώς
και  υδροµετρήσεις  (σποραδικές  µετρήσεις  στάθµης  και  παροχής)  για
αναγωγές  στους  υπολογισµούς  (διόρθωση  stout  -  βλ.  τεύχος  θεωρητικής
τεκµηρίωσης):
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2. Επιλογή του µενού Hydrology→Curve and interpolations:

3. Ανοίγει  µία  φόρµα  που  παρουσιάζει  τις  διαθέσιµες  χρονοσειρές  (available
timeseries) και τις επιλογές που υπάρχουν για αυτές (timeseries selections)
. Ο χρήστης µεταφέρει τις διαθέσιµες χρονοσειρές «τραβώντας» τις στο δεξιό
πάνελ.  Μπορεί  να  καθοριστεί  µέχρι  µία  χρονοσειρά  σε  κάθε  κατηγορία  στο
πάνελ δεξιά.
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Η χρονοσειρά που πρέπει να καθοριστεί υποχρεωτικά είναι αυτή των πυκνών
µετρήσεων (Stage (dense)). Στην συνέχεια µπορεί να καθοριστεί µία ακριβέστερη
χρονοσειρά π.χ. από συµβατικό όργανο (Stage (sparse)) για αναγωγή των πυκνών
µετρήσεων. Η χρήση δύο επιπέδων σταθµηµετρήσεων χρησιµοποιείται τόσο στις
περιπτώσεις υπολογισµού στάθµης - παροχής όσο και στον υπολογισµό στάθµης -
επιφάνειας, όγκου. Ειδικά για τις καµπύλες στάθµης παροχής, ο χρήστης µπορεί να
καθορίσει χρονοσειρές υδροµετρήσεων (στάθµη: HQ - Stage, παροχή: HQ -
Discharge). Επιπλέον οι χρονοσειρές των υδροµετρήσεων είναι απαραίτητες για την
περίπτωση που ο χρήστης θα καταρτίσει νέες καµπύλες στάθµης στάθµης -
παροχής.

4. Κλικ στο κουµπί Info για να εµφανιστουν οι περιγραφές των χρονοσειρών που
απαιτούνται για τους υπολογισµούς και κλείσιµο της φόρµας πατώντας το
κουµπί ΟΚ:
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5. OK στην φόρµα του βήµατος 3. Ανοίγει ο φόρµα των παρεµβολών
χρονοσειρών:

6.2.1 Υπολογισµός παροχής από στάθµη - στερεοπαροχής από παροχή

Ό χρήστης έχει καθορίσει τις χρονοσειρές  στάθµης από σταθήµετρο, σταθµηγράφο,
ενδεχοµένως  και  υδροµετρήσεις,  όπως  περιγράφεται  στο  προηγούµενο
υποκεφάλαιο.  Ο  υπολογισµός  στάθµης  -  παροχής  µπορεί  να  πραγµατοποιηθεί
ακόµα και αν διατίθεται µόνο µία χρονοσειρά στάθµης (η οποία θα πρέπει να οριστεί
ως «πυκνή» - "dense").

1. Ο  χρήστης  επιλέγει  υπολογισµούς  στάθµης  -  παροχής  (Stage-Discharge)
από την παρακάτω λίστα:

2. Στην κεντρική φόρµα των παρεµβολών χρονοσειρών, ο χρήστης φορτώνει ένα
σετ καµπυλών στάθµης - παροχής χρησιµοποιώντας το κουµπί Open Curves
from File:
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3. Οι  καµπύλες  φορτώνονται  και  απεικονίζονται  ως  γράφηµα.  Επιπλέον  ο
χρήστης  µπορεί  να  εµφανίσει  τα  σηµεία  των  υδροµετρήσεων  πατώντας  το
κουµπί "Show H-Q Points":

Όπως  φαίνεται  στο  παραπάνω  σχήµα,  η  καµπύλη  επέκτασης  (κόκκινη)  είναι  εκτός
της εµβέλειας των υδροµετρήσεων.

4. Καθορίζονται  οι  υπολογισµοί  που  θα  πραγµατοποιηθούν  χρησιµοποιώντας
την παρακάτω οµάδα κουµπιών:

• Make  H1  Correction:  Αναγωγή  της  πυκνής  χρονοσειράς  (π.χ.  σταθµηγράφου)
από µία ακριβέστερη χρονοσειρά (π.χ. σταθµήµετρο).

• Merge Sparse+Dense Stage Data: Συνένωση  της  ανηγµένης  µε  H1 χρονοσειράς
(πυκνή) µε την ακριβέστερη (αραιή).
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• Make H2 Correction (from H-Q):  Σαν  την  διόρθωση  H1,  έχει  νόηµα  µόνο  στους
υπολογισµούς  στάθµης  παροχής,  οπότε  και  ανάγονται  οι  χρονοσειρές  µε  τις
ακριβείς µετρήσεις στάθµης κατά τις υδροµετρήσεις.

• Make  Stout  Correction:  Έχει  νόηµα  µόνο  στους  υπολογισµούς  στάθµης  -
παροχής,  διόρθωση  τύπου  Stout  (Stage  Correction,  βλ.  τεύχος  θεωρητικής
τεκµηρίωσης).

• Calculate  discharge:  Τελικοί  υπολογισµοί  εφαρµόζοντας  την  καµπύλη  ώστε  να
υπολογιστεί  η  τελική  παροχή.  Ο  τελικός  υπολογισµός  είναι  προαιρετικός,  ο
χρήστης έχει την δυνατότητα να κάνει µόνο τις αναγωγές και να λάβει διορθωµένες
τιµές για την στάθµη.

5. Εάν  κάποιες  µετρήσεις  στάθµης  δεν  καλύπτονται  ηµερολογιακά  από  κάποια
καµπύλη  στάθµης  -  παροχής,  κάποιο  µήνυµα  λάθους  προειδοποιεί  τον
χρήστη.

6. Ο χρήστης πατάει το κουµπί "Calculate". Οι υπολογισµοί ολοκληρώνονται µε
εµφάνιση  των  χρονοσειρών  στην  φόρµα  επεξεργασίας.  Εµφανίζονται  όλες  οι
ενδιάµεσες χρονοσειρές που προκύπτουν από τις αναγωγές σταθµών:
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Υπολογισµος στερεοπαροχής από παροχή 
Ο υπολογισµός γίνονται µε τις βασικές αρχές που παρουσιάζεται στο παρόν
υποκεφάλαιο καθώς και στην Κατάρτιση καµπυλών στάθµης-παροχής / παροχής-
στερεοπαροχής. Ο χρήστης επιλέγει αρχικά υπολογισµούς παροχής-στερεοπαροχής
(Discharge-Sediment Discharge) και στη συνέχεια ακολουθεί τα ίδια βήµατα.

6.2.2 Κατάρτιση καµπυλών στάθµης-παροχής / παροχής-στερεοπαροχής

Ο  χρήστης  έχει  καθορίσει  ήδη  στο  προηγούµενο  βήµα  (βλ.  υποκεφάλαιο  «
Υπολογισµός  παροχής  από  στάθµη»)  χρονοσειρές  υδροµετρήσεων.  Επιπλέον
µπορεί  να  έχει  φορτώσει  καµπύλες  στάθµης-παροχής  ή  παροχής-στερεοπαροχής.
Σε αυτό το στάδιο ο χρήστης είτε επεξεργάζεται  τις υπάρχουσες  καµπύλες που έχει
φορτώσει είτε καταρτίζει νέες καµπύλες.

1. Στην φόρµα υπολογισµών ο χρήστης πατάει το κουµπί "Edit":
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2. Ένα  νέο  παράθυρο  ανοίγει  το  οποίο  παρέχει  δυνατότητες  κατάρτισης
καµπυλών στάθµης - παροχής:
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3. Αν  ο  χρήστης  δεν  έχει  καθορίσει  τις  χρονοσειρές  στο  προηγούµενο  στάδιο,
µπορεί  να  χρησιµοποιήσει  το  µενού  Timeseries→Import Timeseries,  οπότε
ανοίγει  ένα  παράθυρο  όπου  ο  χρήστης  καθορίζει  τις  χρονοσειρές  των
υδροµετρήσεων:  στάθµη  (stage)  και  παροχή  (discharge)  ή  παροχή  (
discharge) και στερεοπαροχή (sediment discharge). 

4. Χρησιµοποιώντας  τα  κουµπία  Insert  και  Add,  δηµιουργούνται  περίοδοι
εγκυρότητας για τα σηµεία:
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Κάθε  περίοδος  χαρακτηρίζεται  µε  ένα  χρώµα.  Τα  σηµεία  των  υδροµετρήσεων
χρωµατίζονται ανάλογα µε το χρώµα της ηµερολογιακής περιόδου που ανήκουν. Σε
ένα  ραβδόγραµµα  στο  κάτω  µέρος  της  οθόνης  παρουσιάζεται  η  γραφική
αναπαράσταση  των  διαφορετικών  περιόδων.  Ο  χρήστης  µπορεί  να  εναλλάσσει
µεταξύ  των  περιόδων  είτε  κάνοντας  κλικ  στην  λίστα  πάνω  από  τα  κουµπιά  Insert,
Add, Remove... είτε στις ράβδους του ραβδογράµµατος.
Για τις καµπύλες στάθµης-παροχής µπορεί να χρησιµοποιηθεί το κουµπί "Extension
"  για  να  προστεθεί  µία  και  µοναδική  καµπύλη  επέκτασης  µε  περίοδο  εγκυρότητας
που  περιλαµβάνει  όλο  το  δείγµα  υδροµετρήσεων.  Η καµπύλη  επέκτασης  µπορεί  να
υπολογιστεί µόνο µε υδραυλική µέθοδο ή µε Paste (επικόληση) δεδοµένων.

5. Η έναρξη και το πέρας κάθε περιόδου ελέγχεται αναλυτικά από τα πεδία Start
date  και  End  date.  Στην  περίπτωση  µεταβολής  τους,  ο  χρήστης  πρέπει  να
πατήσει Apply για να γίνει αποδεκτή η αλλαγή:



Υ∆ΡΟΓΝΩΜΩΝ72

(c) 2009 Εθνικό Μετσόβιο Πολυτεχνείο

6. Η  αναζήτηση  των  περιόδων  διευκολύνεται  αν  προβάλεται  µία  περίοδος  κάθε
φορά,  απενεργοποιώντας  την  επιλογή  του  κουµπιού  "Show all".  Η  περίοδος
µπορεί  να  ρυθµιστεί  «τραβώντας»  τους  ρυθµιστικούς  δροµείς  κάτω  από  την
περίοδο:

Χρησιµοποιώντας  την  επιλογή  µενού  Tools→Fix  overlaping  dates,  το  σύστηµα
φροντίζει  κατά  την  µετακίνηση  των  δροµέων  ώστε  να  µην  επικαλύπτονται  οι
περιόδοι.
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7. Τα κουµπιά "Curves" και "Points" ελέγχουν την εµφάνιση ή µη καµπυλών και
σηµείων.  Χρησιµοποιώντας  το  κουµπί  "Outlier"  ο  χρήστης  µαρκάρει
εξωκείµενα σηµεία τα οποία δεν συµπεριλαµβάνονται στους υπολογισµούς:

8. Οι  καµπύλες  για  κάθε  περίοδο  χωριστά  υπολογίζονται  είτε  µε  βέλτιστη
προσαρµογή ελαχίστων τετραγώνων, είτε µε αντιγραφή και επικόληση (Paste)
από άλλο λογισµικό είτε µε υδραυλική µέθοδο.

9. Η  προσαρµογή  µε  ελάχιστα  τετράγωνα  γίνεται  αφού  ο  χρήστης  επιλέξει
περίοδο και αριθµό τµηµάτων (= αριθµός θλάσεων - 1). Στην συνέχεια πατάει
το κουµπί "Fit":

Η  τιµή  της  µετατόπισης  (Offset)  πρέπει  να  είναι  τέτοια  ώστε  να  αναιρούνται  οι
αρνητικές τιµές στάθµης. Κάθε καµπύλη µπορεί να έχει διαφορετική τιµή offset, αλλά
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είναι  καλή  τακτική  να  χρησιµοποιείται  η  ίδια  τιµή  για  όλες  τις  καµπύλες.  Η
προκαθορισµένη  (default)  τιµή  αλλάζει  µέσω  της  επιλογής  µενού:  Tools→Change
default  offset,  ενώ  µέσω  της  επιλογής:  Tools→Change  offset  to  all  curves
αλλάζει εκ'των υστέρων η τιµή του offset σε όλες τις καµπύλες. Στην περίπτωση της
στερεοπαροχής δεν χρησιµοποιείται σταθερός όρος για τη µετατόπιση.

10.Προσαρµόζεται µία νέα καµπύλη µε τόσα τµήµατα όσα ζήτησε ο χρήστης. Σε
πίνακα  (Stage  -  Discharge)  παρουσιάζονται  τα  σηµεία  της  καµπύλης.  Ο
χρήστης  µπορεί  να  επέµβει  στις  τιµές  του  πίνακα,  να  τις  αντιγράψει  (Copy)
µέσω  του  πρόχειρου  (Clipboard)  σε  λογισµικό  τύπου  Microsoft  Excel,  αλλά
και  αντιστρόφως  να  φέρει  σηµεία  από  άλλο  λογισµικό  µε  επικόληση  (Paste).
Με  αυτόν  τον  τρόπο  ο  χρήστης  µπορεί  να  εισάγει  καµπύλες  που  έχουν
καταρτιστεί µε άλλο λογισµικό / µεθοδολογία:

11.Συµπληρώνονται όλοι οι περιόδοι µε καµπύλες:
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12.Τυχόν  καµπύλη  επέκτασης  εισάγεται  είτε  µε  Copy  -  Paste  είτε  µε  υδραυλικό
υπολογισµό (βλ. επόµενο υποκεφάλαιο).

13.Αφού  καταρτιστούν  οι  καµπύλες,  κλείνοντας  την  φόρµα,  µεταφέρονται
αυτόµατα στην φόρµα υπολογισµών.

Άλλες επιλογές µενού:

• File→New: Αναίρεση των πάντων, δηµιουργία νέου σετ καµπυλών.

• File→Load / Save: Ανάγνωση και εγγραφή αρχείων µε καµπύλες. Τα αρχεία αυτά
µπορούν να αναγνωστούν και από την φόρµα υπολογισµών.

• File→Print chart: Εκτύπωση των καµπυλών.

• Edit→Undo / Redo: Αναίρεση/Επανάληψη των ενεργειών του χρήστη.

• Edit→Copy chart: Αντιγραφή του γραφήµατος, π.χ. σε κειµενογράφο.

• Tools→Calculate  determination  coefficient:  Υπολογισµός  του  συντελεστή
προσδιορισµού για όλες τις καµπύλες.

• Timeseries→Export  timeseries:  Οι  χρονοσειρές  εξάγονται  στην  φόρµα
επεξεργασίας, έχοντας αφαιρέσει τα εξωκείµενα σηµεία (outliers).

• Wet  Period:  Εισάγεται  το  υποσύνολο  που  αντιστοιχεί  στους  θερινούς  (ξηρή
περίοδο). 

• Dry  Period:   Εισάγεται  το  υποσύνολο  που  αντιστοιχεί  στους  χειµερινούς  µήνες
(υγρή περίοδο). 

6.2.2.1 Υδραυλικές καµπύλες - Καµπύλες επέκτασης

Η  υποµονάδα  κατάρτισης  καµπυλών  στάθµης  -  παροχής  µε  υδραυλικούς
υπολογισµούς βασίζεται σε αναλυτικές µεθόδους (ανοικτοί αγωγοί: σχέσεις Manning
και Chezy) αξιοποιώντας στοιχεία διατοµών, συντελεστές τραχύτητας, κ.α.

1. Στο  στάδιο  κατάρτισης  καµπυλών  στάθµης  παροχής,  ο  χρήστης  επιλέγει  µία
καµπύλη (π.χ. την καµπύλη επέκτασης), κατόπιν πατάει το κουµπί "Hydraulic
":



Υ∆ΡΟΓΝΩΜΩΝ76

(c) 2009 Εθνικό Μετσόβιο Πολυτεχνείο

2. Μία νέα φόρµα ανοίγει:

O Χρήστης προσδιορίζει την γεωµετρία της διατοµής ορίζοντας µία αριστερόστροφη
πολυγωνική.  Πατώντας  το  κουµπί  "Insert  /  add"  προσθέτει  στην  λίστα  σηµεία  τα
οποία  στην  συνέχεια  τα  συµπληρώνει  µε  συντεταγµένες.  Τα  σηµεία  µπορούν  να
προέρχονται  π.χ.  από  το  Microsoft Excel και  να  εισαχθούν  µε  Paste (Edit→Paste).
Ο χρήστης σε κάθε περίπτωση µπορεί να επεµβαίνει στις τιµές των συντεταγµένων.
Πατώντας το κουµπί "Refresh" οι αλλαγές αυτές σχεδιάζονται στο διάγραµµα.
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3. Στο  συγκεκριµένο  παράδειγµα  δηµιουργείται  αυτόµατα  µία  τραπεζοειδής
διατοµή  (λειτουργία  µενού:  Tools→Add  a  trapezoid  section).  Ο  χρήστης
ερωτάται για τις διαστάσεις του τραπεζίου, στην συνέχεια σχεδιάζεται:

Στο  σηµείο  αυτό  πρέπει  να  τονιστεί  πως  η  στάθµη  0  (τετµηµένη  διατοµής  0)
αντιστοιχεί  στο  πραγµατικό  κατώτατο  σηµείο  της  διατοµής.  Στην  συνέχεια  αφού
υπολογιστεί η σχέση στάθµης - παροχής, θα προστίθεται  η µετατόπιση (offset) που
έχει καθοριστεί για την καµπύλη.

4. Ο  χρήστης  καθορίζει  το  υδραυλικό  µοντέλο  (Manning  ή  Chezy).  Στην
συνέχεια  καθορίζει  την  υδραυλική  κλίση  (Slope)  καθώς  και  τον  συντελεστή
τραχύτητας, ωστόσο έχει την δυνατότητα να καθορίσει και ένα ενιαίο γινόµενο
-  συντελεστής  (unified  coefficient,  βλ.  τεύχος  θεωρητικής  τεκµηρίωσης).  Ο
ενιαίος  συντελεστής  µπορεί  να  υπολογιστεί  και  µε  βέλτιστη  προσαρµογή,
χρησιµοποιώντας έναν αριθµό από τις υδροµετρήσεις µε τις υψηλότερες τιµές
(Number  of  max  points  for  fitting).  Τελικά  πατώντας  το  κουµπί  "Fit",  ένας
ενιαίος συντελεστής υπολογίζεται αυτόµατα:
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5. Ο  τελικός  υπολογισµός  της  καµπύλης  γίνεται  αφού  καθοριστούν  τα  όρια
στάθµης  (Minimum  Stage,  Maximum  Stage),  ο  αριθµός  των  τµηµάτων  (
Segments)  και  αν  θα  χρησιµοποιηθεί  λογαριθµικός  νόµος  παρεµβολής  (Log
segments):

6. Ο  χρήστης  πατάει  το  κουµπί  Calculate  στο  πέρας  του  βήµατος  5.  Η  φόρµα
κλείνει  και  η  καµπύλη  απεικονίζεται  στην  φόρµα  κατάρτισης  καµπυλών  (µε
κόκκινο χρώµα παρακάτω):
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Άλλες επιλογές µενού:

• File→New: Αναίρεση όλων, δηµιουργία νέας διατοµής.

• File→Load: Φόρτωση διατοµής από αρχείο.

• File→Save: Εγγραφή διατοµής σε αρχείο.

• File→Print chart: Εκτύπωση του διαγράµµατος της διατοµής.

• Edit→Undo / Redo: Αναίρεση / Επανάληψη της τελευταίας ενέργειας.

• Edit→Copy / Paste: Αντιγραφή / Επικόληση των συντεταγµένων της διατοµής.

• Edit→Copy chart: Αντιγραφή του γραφήµατος.

• Edit→Insert / Remove node: Αναπαράγουν τα κουµπία Insert / add, Remove για
την εισαγωγή ή την διαγραφή κόµβων της διατοµής.

• Tools→Move / Scale section: Μετατόπιση ή αλλαγή κλίµακας της διατοµής.

• Tools→Add  a  ....  section:  Αυτόµατη  εισαγωγή  διατοµής  από  µία  λίστα
προκαθορισµένων διατοµών (ορθογωνική, τραπεζοειδής, κυκλική, κ.α.)

6.2.3 Στάθµη - επιφάνεια, όγκος ταµιευτήρα και λοιποί υπολογισµοί

Υπολογισµός στάθµης - επιφάνειας όγκου ταµιευτήρα
1. Ο χρήστης επιλέγει υπολογισµούς στάθµης - επιφάνειας, όγκου (Stage-Area,

Volume) από την παρακάτω λίστα:

2. Ο χρήστης φορτώνει από αρχείο (Load Curves - from file) σετ καµπυλών: 

Το  αρχείο  πρέπει  να  είναι  αρχείο  κειµένου  (Text  file)  µε  τρεις  στήλες  (στάθµη,
επιφάνεια,  όγκος  -  η  στάθµη  ταξινοµηµένη  σε  αύξουσα  σειρά).  Κατά  την  φόρτωση
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των  δεδοµένων,  ο  χρήστης  καθορίζει  τον  σύµβολο  της  υποδιαστολής  (Decimal
separator) καθώς και τον διαχωριστή των στηλών (Delimiter). 

3. Οι καµπύλες απεικονίζονται:
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4. Εάν έχει καθοριστεί ακριβής χρονοσειρά (Sparse time series), ενεργοποιείται
η δυνατότητα αναγωγής των σταθµών µε H1 (βλ. υπολογισµός παροχής από
στάθµη).

5. Πατώντας το κουµπί Calculate οι υπολογισµοί ολοκληρώνονται µε τις
χρονοσειρές εξόδου (επιφάνεια και όγκος) να απεικονίζονται σε νέες στήλες
στην φόρµα επεξεργασίας χρονοσειρών:

Υπολογισµοί υπογείων διαφυγών ταµιευτήρα / παροχής υπερχείλισης από
στάθµη υπερχειλιστή φράγµατος
Οι υπολογισµοί γίνονται µε τις βασικές αρχές που παρουσιάζονται στο παρόν
υποκεφάλαιο καθώς και στο υποκεφάλαιο του υπολογισµού παροχής από στάθµη. Ο
χρήστης επιλέγει είτε υπολογισµό διαφυγών (Stage-Leakage) ταµιευτήρα, είτε
υπολογισµό στάθµης - παροχής υπερχειλιστή (Spillway Stage-Discharge):
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6.3 Παλινδρόµηση - Συµπλήρωση ελλείψεων

Με  τις  λειτουργίες  παλινδρόµησης  και  συµπλήρωσης,  εφαρµόζονται  διάφορες
µεθοδολογίες  συσχέτισης  χρονοσειρών  και  συµπλήρωση  ελλείψεων,  οι  οποίες
αναπτύσσονται στο τεύχος θεωρητικής τεκµηρίωσης.

1. Αρχικά ο χρήστης ανοίγει τις χρονοσειρές που θα χρησιµοποιήσει:
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Μία  ακριβώς  χρονοσειρά  θα  είναι  η  λεγόµενη  «εξαρτηµένη» χρονοσειρά.  Μπορούν
να  υπάρχουν  και  «ανεξάρτητες» χρονοσειρές,  από  µία  έως  πολλές.  Ανάλογα  µε  τη
µεθοδολογία  που  θα  ακολουθηθεί  µπορούν  να  χρησιµοποιούνται  από  καµία  έως
πολλές ανεξάρτητες.

2. Επιλογή του µενού Hydrology→Regression and infilling:

3. Ανοίγει  µία  φόρµα  που  παρουσιάζει  τις  διαθέσιµες  χρονοσειρές  (available
timeseries) και τις επιλογές που υπάρχουν για αυτές (timeseries selections)
. Ο χρήστης µεταφέρει τις διαθέσιµες χρονοσειρές «τραβώντας» τις στο δεξιό
πάνελ.
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Πρέπει  να  καθορίζεται  υποχρεωτικά  µία  ακριβώς  εξαρτηµένη  χρονοσειρά  ενώ  οι
ανεξάρτητες χρονοσειρές µπορούν να είναι από καµία έως αρκετές.

4. κλικ στο κουµπί Info και κλείσιµο της φόρµας πατώντας το κουµπί ΟΚ

5. Με OK προχωράει η επεξεργασία και ανοίγει το παράθυρο επιλογών:
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• Order  of  auto-correlation:  Βαθµός  αυτοσυσχέτισης.  Η  εξαρτηµένη  χρονοσειρά
συσχετίζεται  µε  τον  εαυτό  της  τόσες  φορές  όσο  ο  βαθµός  αυτοσυσχέτισης  και  µε
υστέρηση [1,2,...,order] χρονικά βήµατα. Η αυτοσυσχέτιση µπρορεί να εφαρµοστεί
αυτούσια  στην  εξαρτηµένη  χρονοσειρά  (χωρίς  ανεξάρτητες  χρονοσειρές)  είτε  και
ταυτοχρόνως µε πολλαπλή γραµµική παλινδρόµηση.

• Zero constant  term:  Μηδενικός  σταθερός  όρος  ή  οµογενής  ευθεία:  Εφαρµόζεται
στην απλή ή την πολλαπλή γραµµική παλινδρόµηση, εξαναγκάζοντας σε µηδενικό
σταθερό όρο.

• Calc. only Mean Values: Η λειτουργία αυτή είναι έγκυρη εφόσον έχει επιλεγεί µία
και  µόνο  εξαρτηµένη  χρονοσειρά  και  καµία  ανεξάρτητη.  Υπολογίζεται  ένας
σταθερός όρος ως η µέση τιµή. Η µεθοδολογία αυτή πρέπει να χρησιµοποιείται µε
την επιλογή "Seasonal" και µόνο για την συµπλήρωση µηνιαίων χρονοσειρών όταν
δεν µπορεί να εφαρµοστεί η παλινδρόµηση.

• Organic:  Οργανική  συσχέτιση  µεταξύ  δύο  χρονοσειρών.  Κατάλληλη  για  επέκταση
δειγµάτων καθώς διατηρεί τα στατιστικά χαρακτηριστικά.

• Seasonal:  Εκτελεί  12  ανεξάρτητες  παλινδροµήσεις  σε  12  διαφορετικά  δείγµατα
που  σχηµατίζονται  από  µηνιαίες  τιµές  (ένα  δείγµα  για  κάθε  µήνα  του  χρόνου).
Μπορεί να εφαρµοστεί σε όλες τις µεθοδολογίες ακόµα και στην περίπτωση όπου
υπεισέρχεται η αυτοσυσχέτιση.

• Do  not  regress,  just  use  mean  values.  Συσχέτιση  µόνο  µε  χρήση  της  µέσης
τιµής.  Επιτρέπεται  µόνο  µία  χρονοσειρά  εισόδου  (εξαρτηµένη).  Χρήσιµη  στις
περιπτώσεις  συµπλήρωσης  όταν  δεν  είναι  δυνατή  η  συσχέτιση  µε  γειτονικό
σταθµό. Επιτρέπεται µεταξύ άλλων η χρήση της εποχικότητας.

• Optimize for mutli regression, βελτιστοποίηση, βλ. επόµενη παράγραφο.

• Do filling  on null  records:  Εφαρµόζεται  η  συµπλήρωση  των  κενών  (ελλείψεων)
των χρονοσειρών σύµφωνα µε τα αποτελέσµατα της ανάλυσης της παλινδρόµησης

• Random  term,  Random  seed:  Προσθήκη  τυχαίου  όρου  στις  συµπληρωµένες
τιµές. Αν το random seed είναι  ενεργοποιηµένο, γίνεται  τυχαία αρχικοποίηση  πριν
την  εκτέλεση  της  ανάλυσης,  διαφορετικά  τα  αποτελέσµατα  είναι  ίδια  σε  κάθε
εκτέλεση (προκαθορισµένη συµπεριφορά).

• Truncate negative values to zero: Εάν τυχόν προκύψουν αρνητικές τιµές από την
συµπλήρωση, γίνεται αποκοπή στο µηδέν (0).

• Extend  values  to  the  past,  to  the  future:  Επέκταση  δείγµατος  εξαρτηµένες
χρονοσειράς στο παρελθόν ή / και στο µέλλον.

• Do not fill inner missing values: .Οι ενδιάµεσες ελλείψεις δεν συµπληρώνονται
Ο  χρήστης  πατάει  το  κουµπί  OK  για  να  πραγµατοποιηθεί  η  ανάλυση.  Τα
αποτελέσµατα απεικονίζονται σε ειδικό πίνακα:
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Εφόσον  η  παλινδρόµηση  είναι  εποχική,  δώδεκα  (12)  διαφορετικά  σετ  παραµέτρων
υπολογίζονται. Η πρώτη στήλη (N) είναι το πλήθος των µετρήσεων, η δεύτερη στήλη
είναι  ο  συντελεστής  προσδιορισµού  δ  (D).  Στην  τρίτη  στήλη  απεικονίζεται  ο
συντελεστής  συσχέτισης,  στην  τέταρτη  στήλη  ο  κρίσιµος  συντελεστής  συσχέτισης  (
Dcr) ως το απόλυτο ελάχιστο που πρέπει να πληρεί ο υπολογισµένος συντελεστής.
Στην  συνέχεια  είναι  ο  σταθερός  όρος  (a0)  καθώς  και  οι  υπολογισµένοι  συντελεστές
πολλαπλής  παλινδρόµησης  a1,  ...,  an  συµπεριβαλλοµένων  και  των  συντελεστών
αυτοσυσχέτισης.  Με  την  επιλογη  Show  deviation  chart  ο  χρήστης  µπορεί  να
παράγει  το  γράφηµα  διασποράς  µεταξύ  της  ανεξάρτητης  και  εξαρτηµένης
χρονοσειράς.
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Εάν έχει επιλεχθεί συµπλήρωση, η συµπληρωµένη χρονοσειρά απεικονίζεται σε νέα
στήλη:

6.3.1 Παλινδρόµηση - Βελτιστοποίηση

Η λειτουργία της βελτιστοποίησης έχει νόηµα στην περίπτωση εξέτασης
παλινδρόµησης µίας εξαρτηµένης µεταβλητής και διαφόρων ανεξάρτητων
µεταβλητών σε συνδυασµό µε εποχικότητα (Seasonal).

Εφόσον έχει επιλεχθεί η λειτουργία βελτιστοποίησης “Optimization” στις ρυθµίσεις
για την παλινδρόµηση χρονοσειρών, θα εµφανιστεί στο χρήστη το παρακάτω
παράθυρο:
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Πατώντας σε κάθε κελί ο χρήστης µπορεί να τροποποιήσει τις ρυθµίσεις. Για τις
µεταβλητές οι δυνατότητες είναι αυτόµατη ανεύρεση είναι “Automatic” (Αυτόµατη),
“Always used” (Χρησιµοποιείται πάντα) και “Not used” (∆εν χρησιµοποιείται). Έτσι
για κάθε µήνα καθορίζεται για κάθε χρονοσειρά αν θα δοκιµάζεται για την βέλτιστη
λύση, αν πρέπει οπωσδήποτε να χρησιµοποιηθεί ή αντιθέτως αν δεν πρέπει. Στο
πεδίο “Max time series” καθορίζεται το µέγιστο πλήθος ανεξάρτητων µεταβλητών
ανά µήνα. Στο πεδίο “Only Positives” ο χρήστης καθορίζει αν η λύση θα επιτρέπει
(ρύθµιση False) ή όχι (ρύθµιση True) αρνητικούς συντελεστές στις µεταβλητές.

Πατώντας τελικά “OK” γίνονται οι υπολογισµοί.

Σηµειώνεται πως η βελτιστοποίηση µπορεί να γίνει ακόµα και µε χωρίς τη χρήση
εποχικότητας, για να καθοριστεί π.χ. η µία ανεξάρτητη µεταβλητή που δίνει την
καλύτερη συσχέτιση µε µία εξαρτηµένη.

Τα τελικά αποτελέσµατα απεικονίζονται στον γνωστό πίνακα αποτελεσµάτων:
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Όπου N, το πλήθος των κοινών µετρήσεων ανά µήνα, D ο συντελεστής
προσδιορισµού, R ο συντελεστής συσχέτισης, Dcr ο κρίσιµος συντελεστής
προσδιορισµού a0 ο σταθερός όρος, a1~a4 οι συντελεστές των µεταβλητών.

Ο χρήστης µπορεί να επιλέξει κάποιο µήνα (π.χ. τον ενδέκατο) και στην συνέχεια
πατώντας “Show deviation chart” εµφανίζεται διάγραµµα διασποράς:

Στην περίπτωση πολλαπλής γραµµικής παλινδρόµησης (όπως στο συγκεκριµένο
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παράδειγµα) το διάγραµµα διασποράς δεν απεικονίζει την συσχέτιση ως προς µία
συγκεκριµένη ανεξάρτητη µεταβλητή αλλά ως προς την µέση τιµή των ανεξάρτητων
µεταβλητών, ώστε να µπορεί να απεικονιστεί η παλινδρόµηση στο επίπεδο.

6.4 Ζυγός - Αδροµερής προσοµοίωση υδρολογικών διεργασιών
λεκάνης απορροής

Η µονάδα «Ζυγός» είναι ένα σύστηµα αδροµερούς προσοµείωσης των υδρολογικών
διεργασιών  σε  λεκάνη  απορροής.  Το  µοντέλο  τροφοδείται  µε  χρονοσειρές
βροχόπτωσης,  δυνητικής  εξατµοδιαπνοής  και  αντλήσεων  από  τα  υπόγεια  ύδατα.
Στην συνέχεια ο χρήστης καθορίζει την µορφή του µοντέλου ανοίγοντας ή κλείνοντας
τις  κατάλληλες  «βάνες»  και  καθορίζοντας  τις  παραµέτρους.  Τελικά  το  µοντέλο
παράγει χρονοσειρές απορροής, κατείσδυσης, κλπ.
Μία  σηµαντική  δυνατότητα  του  µοντέλου  είναι  η  αυτόµατη  ρύθµιση  µε  αλγόριθµο
βελτιστοποίησης εάν φυσικά παρέχεται χρονοσειρά µετρηµένων απορροών.

1. Ο χρήστης φορτώνει  χρονοσειράς  βροχόπτωσης,  δυνητικής  εξατµοδιαπνοής,
αντλήσεων και µετρηµένης απορροής. Οι  χρονοσειρές  έχουν µηνιαίο  χρονικό
βήµα.  Η  προσοµοίωση  είναι  δυνατό  να  τρέξει  και  για  διαφορετικά  χρονικά
βήµατα χωρίς όµως αξιόπιστα αποτελέσµατα:
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2. Επιλογή του µενού Hydrology→Zygos - Basin Simulation:

3. Ανοίγει  µία  φόρµα  που  παρουσιάζει  τις  διαθέσιµες  χρονοσειρές  (available
timeseries) και τις επιλογές που υπάρχουν για αυτές (timeseries selections)
. Ο χρήστης µεταφέρει τις διαθέσιµες χρονοσειρές «τραβώντας» τις στο δεξιό
πάνελ.  Μπορεί  να  καθοριστεί  µέχρι  µία  χρονοσειρά  σε  κάθε  κατηγορία  στο
πάνελ δεξιά:



Υ∆ΡΟΓΝΩΜΩΝ92

(c) 2009 Εθνικό Μετσόβιο Πολυτεχνείο



Υδρολογική επεξεργασία δεδοµένων 93

(c) 2009 Εθνικό Μετσόβιο Πολυτεχνείο

Όλες  οι  χρονοσειρές  είναι  εκφρασµένες  σε  χιλιοστά  (mm).  Για  να  προχωρήσει  η
επεξεργασία  πρέπει  να  καθοριστούν  υποχρεωτικά  χρονοσειρές  βροχόπτωσης  (
Rainfall)  και  δυνητικής  εξατµοδιαπνοής  (Evapotraspiration).  Προαιρετικά  ο
χρήστης µπορεί να καθορίσει χρονοσειρά αντλήσεων (Pumping) εφόσον υπάρχουν
σχετικά  δεδοµένα  και  το  «στήσιµο» του  µοντέλου  το  επιτρέπει  (λειτουργία  υπόγειας
δεξαµενής).  Τέλος  αν  υπάρχει  µετρηµένη  απορροή,  ρυθµίζεται  το  πεδίο  Measured
Runoff, οπότε δίνεται δυνατότητα ρύθµισης του µοντέλου.

4. Κλικ  στο  κουµπί  Info  και  κλείσιµο  της  φόρµας  πατώντας  το  κουµπί  ΟΚ.
Εµφανίζονται πληροφορίες για τις απαιτούµενες χρονοσειρές.

5. Στην φόρµα του βήµατος 3, κλικ στο ΟΚ.
6. Η κεντρική φόρµα του «Ζυγός» ανοίγει:
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Οι  διάφορες  δυνατότητες  του  µοντέλου  ενεργοποιούνται  σύµφωνα  µε  τις  επιλογές
του  χρήστη.  Έτσι  για  παράδειγµα  αν  ενεργοποιήσει  την  κατείσδυση  (Percolation)
αυτοµάτως ενεργοποιούνται οι υπόγειες διεργασίες µέσω µίας υπόγειας δεξαµενής (
Ground  Tank).  Αυτό  δίνει  στην  συνέχεια  δυνατότητα  σχηµατισµού  πηγών  (Base
flow),  εξόδου  σε  άλλη  λεκάνη  (Outflow)  και  άντλησης  (Pumping).  Για  να  είναι
δυνατή  η  χρήση  της  άντλησης  πρέπει  ο  χρήστης  να  έχει  καθορίσει  την  αντίστοιχη
χρονοσειρά.  Οι  χρονοσειρές  εξόδου  (αποτελέσµατα)  καθορίζονται  από  τον  χρήστη
στην περιοχή "Output time series"

7. Ενεργοποιώντας  την  δυνατότητα  ρύθµισης  στο  βήµα  6  ("Use  measured
runoff  to calibrate"),  η  δεύτερη  καρτέλα  υπολογισµών  "Calibration"  ελέγχει
την αυτόµατη ρύθµιση του µοντέλου:
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Ο  χρήστης  επιλέγει  τις  παραµέτρους  που  θα  ρυθµιστούν  αυτόµατα  στα  πεδία  "
Calibrate"  ανάβοντας  τους  σχετικούς  διακόπτες.  Σε  αυτήν  την  περίπτωση  οι
παράµετροι  κλειδώνονται  και  απεικονίζονται  µε  κίτρινο  φόντο.  Στην  συνέχει  πρέπει
να  καθοριστούν  τα  όρια  βελτιστοποίησης  των  παραµέτρων  (Minimum -  Maximum
Values).

8. Πατώντας  το  κουµπί  Calibrate,  ξεκινάει  η  διαδικασία  βελτιστοποίησης  -
ρύθµισης:
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Η  διαδικασία  ελέγχεται  µέσω  των  κατακόρυφων  µπαρών  που  δείχνουν  την  εκτίµιση
των  παραµέτρων  σχετικά  µε  τα  όρια.  Η  τιµή  της  αντικειµενικής  συνάρτησης  (
Objective  Function)  είναι  το  µέτρο  της  βελτιστοποίησης  και  ο  χρήστης
παρακολουθεί  συνέχεια  την  βελτίωση  της  συχρόνως  µε  τον  αριθµό  των  βηµάτων  (
Number  of  Iterations).  Ανά  πάσα  στιγµή,  πατώντας  το  κουµπί  Stop  η  ρύθµιση
µπορεί  να  σταµατήσει,  αλλιώς  θα  ολοκληρωθεί  ύστερα  από  1000xn  βήµατα  όπου  n
το  πλήθος  των  παραµέτρων  που  βελτιστοποιείται.  Τελικά  παρουσιάζεται  στο
γράφηµα µία εικόνα της ποιότητας της βελτιστοποίησης. Αφού ρυθµιστεί το µοντέλο
ο  χρήστης  πατάει  το  κουµπί  "Transfer  to  model"  ώστε  οι  παράµετροι  να
µεταφερθούν στο κύριο µοντέλο (σελίδα Simulation).

9. Ο  χρήστης  µπορεί  να  καθορίσει  τις  ηµεροµηνίες  υπολογισµών  µέσω  της
καρτέλας "Dates". Οι ηµεροµηνίες πρέπει να είναι συνεχείς. Μπορεί επιπλέον
να  ορίσει  τις  ηµεροµηνίες  µετρηµένης  απορροής  µε  τις  οποίες  ρυθµίζεται  το
µοντέλο.  Αυτό  µπορεί  να  εφαρµοστεί  σε  ένα  σενάριο  ρύθµισης  µε  κάποια
περίοδο και επαλήθευσης µε κάποια άλλη:

10.Αφού  ρυθµιστεί  το  µοντέλο  και  οι  παράµετροι  µεταφερθούν  στην  κύρια
καρτέλα  (βήµα  8),  ο  χρήστης  πατάει  το  κουµπί  "Calculate"  για  να
πραγµατοποιηθούν οι υπολογισµοί:
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11.Τα αποτελέσµατα είναι οι χρονοσειρές που καθορίζονται στην περιοχή Output
time series:
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Τα  µενού  της  κύριας  φόρµας  του  «Ζυγός»  προσφέρουν  τις  παρακάτω  πρόσθετες
λειτουργίες:

• File→Open  parameters  from  file.../Write  parameters  to  file:  Είναι  δυνατή  η
αποθήκευση  σε  αρχείο  και  η  ανάκτηση  δεδοµένων  σχετικά  µε  όλες  τις
παραµέτρους του µοντέλου, ακόµα και των ορίων βελτιστοποίησης.

• File→Sound: Ηχητική απόδοση της διεργασίας βαθµονόµησης.

• File→Print form: Εκτύπωση της ορατής φόρµας του «Ζυγός».

• File→Printer setup: ∆ιαµόρφωση επιλογών εκτύπωσης.

• Edit→Copy  values/Paste  values:  Αντιγραφή  στο  πρόχειρο  και  κατόπιν  σε
λογισµικό τύπου Microsoft Excel των τιµών των παραµέτρων καθώς και ανάκτηση.

6.5 Καταχώρηση υδροµετρήσεων - Κατάρτιση χρονοσειράς
παροχών από υδροµετρήσεις

Ο  χρήστης  έχει  τη  δυνατότητα  καταχώρησης  στοιχείων  υδροµετρήσεων  σαν
υδατορεύµατα  και  στη  συνέχεια  τη  συρραφή  τους  σε  ένα   αρχείο  το  οποίο  µπορεί
στην  συνέχεια  να  καταχωρηθεί  σε  κάποια  βάση  δεδοµένων.  Το  αρχείο  που  θα
δηµιουργηθεί  θα  περιέχει  στοιχεία  διατοµών,  σταθµηµετρήσεων  καθώς  και
υδροµετρήσεων  σε  διαφορετικά  βάθη,  µε  διάφορες  µεθόδους.  Στην  συνέχεια  ο
χρήστης  µπορεί  να  αξιοποιήσει  αυτά  τα  δεδοµένα  για  τον  αυτοµατοποιηµένο
υπολογισµών  των  µέσων  ταχυτήτων  ή  /  και  των  παροχών  καθώς  και  για  την
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εξαγωγή αυτόνοµων χρονοσειρών στάθµης – παροχής. 

1. Από το βασικό µενού επιλογή Hydrology→Hydrometry...

2. Ο  χρήστης  εισάγει  τη  διατοµή  του  υδατορέµατος  επιλέγοντας  την  αντίστοιχη
διατοµή (π.χ. Segment 1) και στη συνέχεια την εντολή Edit.
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3. Στο  παράθυρο  που  ανοίγει,  έχει  τη  δυνατότητα  να  εισάγει  τα  σηµεία  που
συνθέτουν τη διατοµή  σε  άξονες  X/Y, µε  την  εντολή  Insert / add, ενώ  για  να
διαγράψει κάποιο από τα σηµεία που έχει  εισάγει  µπορεί  να κάνει  χρήση της
εντολής  Remove.  Αφού  ολοκληρώσει  το  σχεδιασµό  της  διατοµής  µπορεί  να
την  αποθηκεύσει  (βασικό  µενού  επιλογή  File→Save),  έτσι  ώστε  να  τη
ξαναχρησιµοποιήσει µελλοντικά αν το θελήσει (File→Load...). Επίσης, έχει τη
δυνατότητα  να  επεξεργαστεί  τη  διατοµή,  µετακινόντας  κάποιο  τµήµα  της  (
Tools→Move section) ή αλλάζοντας το µέγεθος του (Tools→Scale section).
Τέλος,  µπορεί  να  εισάγει  έτοιµα  τµήµατα  διατοµών  µε  κυκλικό,  τετράγωνο,
τραπεζοειδές,  ωοειδές  ή  πεταλοειδές  σχήµα  µε  τις  εντολές  Tools→Add  a
circular section, Add a rectangular section, Add a trapezoid section, Add
a egg-shaped section, Add a petal- shaped section, αντίστοιχα.
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Σηµαντικο:  Για  το  σωστό  υπολογισµό  της  στάθµης,  θα  πρέπει  το  βαθύτερο
σηµείο της διατοµής του υδατορέµατος να έχει τεταγµένη x=0.

4. Στη  συνέχεια  πατώντας  Exit,  επιστρέφει  στο  αρχικό  παράθυρο  όπου  εισάγει
τις τιµές ύψους του ρέµατος για διάφορες χρονικές στιγµές, εισάγοντας πρώτα
την  ηµεροµηνία  (Add)  και  στη  συνέχεια  το  ύψος  (Stage),  τα  οποία  και
αποθηκεύει (Save Stage, Date and validate).
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5. Αν  έχει  στη  διάθεση  του  δεδοµένα  υδροµετρήσεων  ο  χρήστης  έχει  τη
δυνατότητα  να  τα  εισάγει   (Add στo πεδίο  Slices)  αφού  επιλέξει  το  είδος  και
τον  αριθµό  των  µέτρησεων  και  στην  συνέχεια  επιλέξει  την  τεταγµένη  x  στην
οποία  έγιναν.  Για  κάθε  σετ  µετρήσεων  ο  χρήστης  εισάγει  τις  τιµές  τους  στο
πεδίο  µε  τον  τίτλο  Measurements.  Στην  περίπτωση  που  ο  χρήστης  έχει
επιλέξει n αριθµό µετρήσεων µπορεί να ορίσει τον αριθµό τους µε την επιλογή
 Meas. Number. Αφού ολοκληρώσει την εισαγωγή των µετρήσεων ο χρήστης
έχει τη δυνατότητα να επαληθεύσει την ορθή εισαγωγή τους και να υπολογίσει
τη µέση ταχύτητα µε την εντολή Validate and draw slices.
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6. Τέλος  στο  πεδίο  Output  time  series,  ο  χρήστης  επιλέγει  αν  η  χρονοσειρά
που  θα  εξάγει  θα  είναι  χρονοσειρά  παροχής  ή  ταχύτητας  και  µε  την  επιλογή
Calculate εξάγει τις τιµές της.

Μέσω  των  επιλογών  menu  ο  χρήστης  µπορεί  να  καλέσει  επιπλέον  λειτουργίες  οι
οποίες περιγράφονται συνοπτικά:

• File→Open: φορτώνει αποθηκευµένα υδροµετρικά δεδοµένα.

• File→Save, Save as: αποθηκεύει τα υδροµετρικά δεδοµένα που έχει εισάγει.

• File→Print X-Section, Print velocity profile: εκτυπώνει  µία  διατοµή  ή  το  προφιλ
ταχυτήτων

• File→Printer setup: Ρυθµίσεις του εκτυπωτή.

• Edit→X-Section, Velocity profile, Μeasurements table: Αντιγραφή στο πρόχειρο
διατοµής, προφιλ ταχυτήτων ή του πίνακα µετρήσεων.

• Process→Run  without  output  for  validation:  Επαλήθευση  των  δεδοµένων
χωρίς την εξαγωγή χρονοσειράς.

6.6 Χωρική ολοκλήρωση - Επιφανειακή βροχόπτωση

Ο  «υπολογισµός  της  επιφανειακής  βροχόπτωσης»  ή  «χωρική  ολοκλήρωση
σηµειακών  βροχοπτώσεων»  ή  «επιφανειακή  ολοκλήρωση  σηµειακών
βροχοπτώσεων»,  είναι  η  υπολογιστική  διαδικασία  µέσω  της  οποίας  εκτιµάται  ένα
µέσο  µέγεθος  βροχόπτωσης,  τέτοιο  ώστε  αν  πολλαπλασιαστεί  µε  την  επιφάνεια  S
της  λεκάνης  απορροής  να  δίνει  τον  συνολικό  όγκο  του  νερού  που  κατακρηµνίστηκε
στο  σύνολο  της  λεκάνης.  Το  µέγεθος  της  επιφανειακής  βροχόπτωσης  είναι  άµεσα
αξιοποιήσιµο  για  την  κατάρτιση  των  υδατικών  ισοζυγίων  και  την  διενέργεια  των
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προσοµοιώσεων των διεργασιών λεκανών απορροής.

1. Επιλογή του menu Hydrology→Spatial integration - surface rainfall...

2. Ανοίγει  µία  φόρµα  που  παρουσιάζει  τις  διαθέσιµες  χρονοσειρές  (available
timeseries) και τις επιλογές που υπάρχουν για αυτές (timeseries selections). Ο
χρήστης µεταφέρει τις διαθέσιµες χρονοσειρές «τραβώντας» τις στο δεξιό πάνελ.



Υδρολογική επεξεργασία δεδοµένων 105

(c) 2009 Εθνικό Μετσόβιο Πολυτεχνείο

O χρήστης µπορεί να συµπληρώσει από µία έως πολλές χρονοσειρές από τις οποίες
θα υπολογιστεί η επιφανειακή βροχόπτωση.

3. Η βασική φόρµα της χωρικής ολοκλήρωσης περιλαµβάνει ένα πίνακα στον οποίο
ο  χρήστης  εισάγει  το  συντελεστή  βαρύτητας  (Weight),  το  υψόµετρο  (Height)  και
τις συντεταγµένες (X coordinate - Y coordinate) κάθε σηµείου που αντιστοιχεί σε
κάθε  χρονοσειρά.  Στη  συνέχεια  θέτωντας  το  µέσο  ύψος  της  λεκάνης  απορροής  (
Mean  basin  altitude),  καθώς  και  τον  παράγοντα  µείωσης  υψοµέτρου  (Altitude
reduction factor), µπορεί να υπολογήσει τη βαθµίδα ύψους (Calculate gradient).
Επίσης  υπολογίζονται  το  κέντρο  της  περιοχής  ολοκλήρωσης  (Estimate  center),
καθώς  και  οι  συντελεστές  βαρύτητας  για  κάθε  σηµείο  (Estimate weights),  αν  δε
θέλει  να  τους  εισάγει  ο  ίδιος.  Με  την  επιλογή  Calculate  surface  rainfall
δηµιουργείται η νέα χρονοσειρά επιφανειακής βροχόπτωσης, την οποία ο χρήστης
µπορεί να την επεξεργαστή περεταίρω. 

 

Στο διάγραµµα (ύψος - βροχόπτωση), η καφέ ευθεία είναι η ευθεία παλινδρόµησης,
η  πράσινη  απεικονίζει  το  µέσο  υψόµετρο  των  σταθµών,  ενώ  η  κόκκινη  το  µέσο
υψόµετρο  της  λεκάνης  απορροής.  Τα  µπλε  σηµεία  είναι  τα  σηµεία  µέτρησης  της
βροχόπτωσης.

• Ο χρήστης µπορεί να επέµβει στις τιµές του πίνακα. Η βασική πληροφορία
που πρέπει να εισάγει είναι το «Βάρος» (Weight) το οποίο µπορεί να
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προκύψει από γεωγραφική επεξεργασία π.χ. µέσω πολυγώνων Thiessen. Η
default τιµή του βάρους είναι 1/k όπου k το πλήθος των σταθµών. Τα βάρη
δεν είναι ανάγκη να είναι ανηγµένα στην µονάδα, αυτό γίνεται αυτόµατα.
∆ίδεται επιπλέον η δυνατότητα να υπολογιστούν βάρη από τις συν/νες των
σταθµών και µε την µέθοδο της αντίστροφης απόστασης (βλ. παρακάτω).

• Μία ακόµη πληροφορία που µπορεί να εισαχθεί είναι τα υψόµετρα των
σταθµών (Altitude) καθώς και το µέσο υψόµετρο της λεκάνης όπως αυτό
υπολογίζεται µε τοπογραφικές µεθόδους (Mean basin altitude).

• Αφού εισαχθούν τα βάρη και τα υψόµετρα των σταθµών, πατώντας το κουµπί
“Calculate gradient” υπολογίζεται η βροχοµετρική βαθµίδα (Gradient).
Εµφανίζεται επιπλέον ο συντελεστής συσχέτισης (Correlation), ο σταθερός
όρος της ευθείας παλινδρόµησης (Constant term) και ο τελικός συντελεστής
υψοµετρικής αναγωγής (Altitude reduction factor). Ο συντελεστής αυτός
υπεισέρχεται στους τελικούς υπολογισµούς µόνο αν είναι τσεκαρισµένο το
κουµπί “Apply factor”. Ο χρήστης µπορεί να τροποποιήσει κατά βούληση το
συντελεστή υψοµετρικής αναγωγής. Τέλος θα εµφανιστεί στο γράφηµα η
ευθεία παλινδρόµησης, τα σηµεία µε τα µέσα ύψη βροχόπτωσης των
σταθµών, καθώς και οι στάθµες του µέσου υψοµέτρου της λεκάνης (Mean
basin altitude) και του µέσου υψοµέτρου του σταθµού (Mean station altitude).

• Υπάρχει η δυνατότητα εκτίµησης των βαρών από τις συν/νες των σταθµών
(εφόσον έχουν εισαχθεί στον πίνακα). Ο χρήστης µπορεί να εισάγει επιπλέον
την θέση του κέντρου της λεκάνης (Center) (προσδιορισµένο µε τοπογραφικές
µεθόδους, π.χ. µε GIS). Αν δεν µπορεί να είναι γνωστή, τότε µπορεί να
πατήσει το κουµπί “Estimate center” και λαµβάνεται το γεωµετρικό κέντρο
βάρους των σταθµών. Στην συνέχεια πατώντας “Estimate weights”
εκτιµώνται βάρη µε τη µέθοδο της αντιστρόφου απόστασης.



Μέρος

Στατιστική ανάλυση χρονοσειρών
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7 Στατιστική ανάλυση χρονοσειρών

Η στατιστική ανάλυση των χρονοσειρών µε το λογισµικό «Υδρογνώµων» συνίσταται
από τις εξής λειτουργίες:

• Στατιστική επεξεργασία χρονοσειρών (Πυθία). Κατά την επεξεργασία αυτή
υπολογίζονται  τα  στατιστικά  χαρακτηριστικά  των  χρονοσειρών  (στατιστικά
χαρακτηριστικά  δείγµατος)  και  προσαρµόζονται  στατιστικές  συναρτήσεις
κατανοµής. Στην συνέχεια ο  χρήστης  µπορεί  να  ελέγξει  την  προσαρµογή  του
δείγµατος  στις  συναρτήσεις  κατανοµής  αλλά  να  κάνει  και  προβλέψεις
(forecasts),  στατιστικούς  ελέγχους  (test)  καθώς  και  εκτίµηση  διαστηµάτων
εµπιστοσύνης.

• Ανάλυση  εξαιρετικών  υδρολογικών  γεγονότων.  Με  την  ειδική  αυτή
λειτουργία συνάθροισης, παράγονται ετήσιες ή µηνιαίες χρονοσειρές µεγίστων
εντάσεων  ή  υψών  βροχόπτωσης  συγκεκριµένης  διάρκειας.  Τα  αποτελέσµατα
αυτής  της  ανάλυσης  αξιοποιούνται  στην  συνέχεια  για  την  κατάρτιση  όµβριων
καµπυλών.

• Κατάρτιση όµβριων καµπυλών (Όµβρος). Ένα εξελιγµένο σύστηµα για την
κατάρτιση όµβριων καµπυλών µε δυνατότητες προσαρµογής από ένα πλήθος
στατιστικών  κατανοµών,  εύρεση  διαστηµάτων  εµπιστοσύνης  σε  όµβρια
καµπύλη, κ.α.

Οι  λειτουργίες  αυτές  του  «Υδρογνώµονα»  εµφανίζονται  κάτω  από  το  menu
Hydrology στην φόρµα επεξεργασίας δεδοµένων.

7.1 Πυθία - Στατιστική επεξεργασία χρονοσειρών

Μέσω της µονάδας «Πυθία» δίνονται δυνατότητες στατιστικής ανάλυσης σε δείγµατα
που  σχηµατίζονται  από  τα  δεδοµένα  χρονοσειρών.  Ο  χρήστης  µπορεί  να  εκτιµήσει
στην  συνέχεια  τα  στατιστικά  χαρακτηριστικά  του  δείγµατος,  να  προσαρµόσει
στατιστικές  κατανοµές  και  να  εκτελέσει  στατιστικές  προγνώσεις.  Η  ανάλυση  γίνεται
επί  χρονοσειρών  µηνιαίου  η  ετήσιου  χρονικού  βήµατος.  Στην  πρώτη  περίπτωση  το
δείγµα χωρίζεται σε δώδεκα (12) επιµέρους δείγµατα, ένα για κάθε µήνα.

1. Ο χρήστης επιλέγει την χρονοσειρά στην οποία θα εκτελεστεί η ανάλυση, αυτή
µάλιστα  θα  είναι  η  ενεργή  χρονοσειρά.  Στο  παρακάτω  παράδειγµα  έχει
φορτωθεί µία ετήσια και µία µηνιαία χρονοσειρά. Θα εκτελεστεί η ανάλυση σε
κάθε µία χωριστά:
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2. Χρήση του µενού Hydrology→Pythia - Statistical analysis:

3. Για την περίπτωση της ετήσιας χρονοσειράς η εικόνα που λαµβάνει ο χρήστης
είναι η παρακάτω:
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ενώ στην περίπτωση της µηνιαίας χρονοσειράς:
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Οι καρτέλες στο κάτω µέρος του γραφήµατος εναλλάσσουν τα διαφορετικά (µηνιαία)
δείγµατα. Ειδικά µε την καρτέλα "All data" σχηµατίζεται ένα ενιαίο δείγµα µε τις τιµές
από  όλους  τους  µήνες.  Στο  αριστερό  τµήµα  είναι  η  γραφική  απεικόνιση  της
εµπειρικής  κατανοµής  (Empirical  Distribution),  τα  σηµεία  δηλαδή  µε  τις  τιµές  της
χρονοσειράς  και  οι  καµπύλες  κατανοµών  (Distribution curves)  όπως  προκύπτουν
από  την  προσαρµογή  των  θεωρητικών  κατανοµών  στο  δείγµα.  Στο  δεξί  µέρος  ο
χρήστης  µπορεί  να  «ανάψει»  ή  να  «σβήσει»  κατανοµές  υπολογισµένες  µε  δύο
διαφορετικές  µεθοδολογίες  (µέθοδος  ροπών  -  Moment Method  καθώς  και  µέθοδος
L-ροπών - L-Moments). Η πρώτη στήλη από κουµπιά στην περιοχή των κατανοµών
αντιστοιχεί  στην  µέθοδο  ροπών  ενώ  η  δεύτερη  (ηµισυµπληρωµένη)  στήλη  στην
µέθοδο L-ροπών.

4. Ο  χρήστης  επιλέγει  την  καρτέλα  "Parameter  evaluation  -  Forecasts"  και  έχει
µία  εικόνα  των  στατιστικών  παραµέτρων  του  δείγµατος  και  των  στατιστικών
κατανοµών (ανά µήνα):
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5. Μέσω  των  επιλογών  του  µενού  Forecasts  ο  χρήστης  κάνει  στατιστικές
προγνώσεις:
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Στο  συγκεκριµένο  παράδειγµα  επιλέχθηκε  πρόγνωση  για  περίοδο  επαναφοράς  ίση
µε 120 έτη. Ο υπολογισµός έγινε για τον µήνα Οκτώβριο καθώς αυτός ήταν ο µήνας
που απεικονιζόταν στην σελίδα γραφηµάτων.

6. Μέσω των επιλογών του µενού Test ο χρήστης εκτελεί στατιστικούς ελέγχους
για τις κατανοµές. Επιλέγοντας Test→X-Square test, ζητείται από τον χρήστη
να  ορίσει  αριθµό  κλάσεων  (βλ.  τεύχος  θεωρητικής  τεκµηρίωσης).  Ο  χρήστης
µπορεί να αποδεχθεί την προτεινόµενη τιµή όπως προκύπτει από τις σχετικές
ανισότητες και δίνοντας OK λαµβάνει τα αποτελέσµατα του τεστ:
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Η λέξη REJECT αντιστοιχεί  σε µη-αποδοχή της κατανοµής ενώ η λέξη ACCEPT  σε
επιτυχία του τεστ για διάφορα επίπεδα σηµαντικότητας (εδώ φαίνονται τα 1%, 5% και
10%). Ο πίνακας του test κλείνει µέσω του µενού View→Refresh parameters table
ή  µε  το  πλήκτρο  F5,  οπότε  ο  πίνακας  επιστρέφει  σε  κατάσταση  απεικόνισης  των
παραµέτρων των κατανοµών.

7. Τα  διαστήµατα  εµπιστοσύνης  των  κατανοµών  υπολογίζονται  µέσω  µίας
διαδικασία  στοχαστικής  προσοµοίωσης  -  Monte  Carlo.  Η  επεξεργασία
ανάλογα µε την ισχύ του υπολογιστή  και  το  πλήθος  του  δείγµατος  µπορεί  να
διαρκέσει έως αρκετά λεπτά. Ο χρήστης επιλέγει την επιθυµητή κατανοµή από
τα  µενού  Confidence,  στην  συγκεκριµένη  περίπτωση  διαστήµατα
εµπιστοσύνης της κατανοµής Γάµα:
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Οι  παράµετροι  των  υπολογισµών  των  διαστηµάτων  εµπιστοσύνης  µπορούν  να
ρυθµιστούν µέσω της επιλογής µενού Confidence→Settings,  οπότε  εµφανίζεται  το
παρακάτω παράθυρο επιλογών:

Τέλος  είναι  δυνατή  η  στατιστική  πρόγνωση  παρεµβάλοντας  στις  καµπύλες  των
διαστηµάτων  εµπιστοσύνης.  Μέσω  της  επιλογής  µενού  Confidence→Forecasts:
∆ίνοντας την τιµή 90%:
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Παρουσιάζονται οι τιµές των σηµείων των καµπυλών (της κατανοµής και των ορίων
εµπιστοσύνης) και τέλος η επιθυµητή τιµή που προκύπτει µε παρεµβολή.

Μέσω  των  επιλογών  menu  ο  χρήστης  µπορεί  να  καλέσει  επιπλέον  λειτουργίες  οι
οποίες περιγράφονται συνοπτικά:

• File→Print chart: εκτύπωση του γραφήµατος των συναρτήσεων κατανοµής

• Edit:  λειτουργίες  αντιγραφής  των  πινάκων  ή  των  γραφηµάτων  στο  πρόχειρο
(clipboard)  και  κατόπιν  σε  λογισµικό  τύπου  Microsoft  Excel  ή  σε  επεξεργαστή
κειµένου, κλπ

• View→Paper  type:  ο  χρήστης  µπορεί  να  επιλέξει  µεταξύ  διαφορετικών  «χαρτιών
κατανοµής».  Τα  χαρτιά  κατανοµής  γραµµικοποιούν  την  απεικόνιση  ορισµένων
κατανοµών,  π.χ.  το  χαρτί  κανονικής  κατανοµής  (Normal)  γραµµικοποιεί  την
κανονική κατανοµή.

• View→Horiz.  axis  is:  ο  χρήστης  επιλέγει  την  µορφή  του  οριζοντίου  άξονα
απεικόνισης  µεταξύ  πιθανότητας  υπέρβασης,  πιθανότητας  µη  υπέρβασης  και
περιόδου επαναφοράς µεγίστων και ελαχίστων.

• View→Refresh  parameters  table:  η  επιλογή  αυτή  ενεργοποιείται  και  µε  το
πλήκτρο F5, οπότε ο πίνακας παραµέτρων ανανεώνεται.

• Options→Unbiased  evaluation:  οι  στατιστικές  παράµετροι  υπολογίζονται  µέσω
αµερόληπτων εκτιµιτριών.

• Options→Set Max x value: ο χρήστης τροποποιεί τα όρια σχεδίασης

• Options→Specify K (shape parameter): ορίζεται η τιµή κ για την κατανοµή τύπου
ΓΑΤ (βλ. θεωρητική τεκµηρίωση)

• Options→Negative values: Truncated to 0: οι αρνητικές τιµές αποκόπτονται στο
µηδέν (0)



Στατιστική ανάλυση χρονοσειρών 117

(c) 2009 Εθνικό Μετσόβιο Πολυτεχνείο

7.2 Ανάλυση εξαιρετικών υδρολογικών γεγονότων

Η  διαδικασία  κατάρτισης  χρονοσειρών  µεγίστων  βροχοπτώσεων  είναι  ένα
απαραίτητο υπολογιστικό βήµα για την στατιστική ανάλυση εξαιρετικών υδρολογικών
γεγονότων, την κατάρτιση όµβριων καµπυλών, κλπ.
Οι αρχικές χρονοσειρές που χρησιµοποιούνται για την παραγωγή των χρονοσειρών
µεγίστων  είναι  µικρού  χρονικού  βήµατος:  δεκάλεπτου,  ωριαίου  ή  ηµερήσιου.  Το
τελικό  προϊόν  είναι  µία  µηνιαία  ή  ετήσια  (που  είναι  το  πιο  σύνηθες)  χρονοσειρά  η
οποία περιέχει  την µέγιστη τιµή του έτους. Οι  αρχικές χρονοσειρές  πρέπει  να έχουν
αυστηρό  χρονικό  βήµα.  (βλ.  Κανονικοποίηση  χρονικού  βήµατος,  Μετατροπή  του
βήµατος των χρονοσειρών σε κανονικό).
Τα  µέγιστα  αφορούν  συναθροισµένες  βροχοπτώσεις  διάρκειας  ακεραίων
πολλαπλασίων του αρχικού χρονικού βήµατος (π.χ. 10, 20, 30 λεπτά, 1 ώρα, κλπ).

1. Από το βασικό µενού, επιλογή Hydrology→Extremes evaluation...

η  επεξεργασία  γίνεται  επί  της  ενεργούς  χρονοσειράς  η  οποία  πρέπει  να  έχει
δεκάλεπτο, ωριαίο ή ηµερήσιο χρονικό βήµα.

2. Μία  φόρµα  ανοίγει  όπου  ο  χρήστης  συµπληρώνει  τις  παραµέτρους
υπολογισµού:
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Η  βασικότερη  παράµετρος  που  ελέγχει  το  τελικό  αποτέλεσµα  είναι  ο
πολλαπλασιαστής (Multiplier). Έτσι επεξεργάζοντας µία δεκάλεπτη χρονοσειρά (ten
minutes),  προκύπτει  η  εξής  χρονοσειρά  µεγίστων  σύµφωνα  µε  τον
πολλαπλασιαστή:

Πολλαπλασιαστής Χρονοσειρά µεγίστων για διάρκεια
βροχόπτωσης d=

1 10 λεπτών

3 30 λεπτών

6 1 ώρας

12 2 ωρών

36 6 ωρών

72 12 ωρών

144 24 ωρών

288 2 ηµέρες

Ο χρήστης πρέπει στην συνέχεια να καθορίσει:

• IDF  timestep:  Το  χρονικό  βήµα  της  τελικής  χρονοσειράς.  Η  προκαθορισµένη
επιλογή είναι η ετήσια (Yearly), εναλακτικά η µηνιαία (Monthly).

• IDF  variable:  Η  µεταβλητή  της  παράγωγης  χρονσοειράς  µπορεί  να  είναι  είτε  το
ύψος βροχόπτωσης σε mm (Height) είτε η ένταση σε mm/h (Intensity).

• Hydrological  Year:  Στην  περίπτωση  παραγωγής  ετήσιας  χρονοσειράς  θα
χρησιµοποιείται το υδρολογικό έτος.

• Accumulate Missing values:  Θα  παράγεται  αποτέλεσµα  για  κάποιο  µήνα  ή  έτος
ακόµα και αν περιλαµβάνονται ελλειπούσες τιµές.

• Calculate missing values percent timeseries (%): Θα εµφανίζεται µία νέα στήλη
χρονοσειράς µε το ποσοστό (%) των ελλείψεων.

• Raise flag when acc. missing: Σε περίπτωση που λείπουν τιµές από κάποιο έτος
ή µήνα θα αίρεται η σηµαία που καθορίζει ο χρήστης σε αυτό το πεδίο. Η επιλογή
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αυτή χρησιµοποιείται σε συνδιασµό µε την επιλογή "Accumulate Missing values".

• Raise flag for marginal values: Η σηµαία που θα αίρεται για τις τιµές περιθωρίου.

7.3 Όµβρος - Κατάρτιση όµβριων καµπυλών

Οι  όµβριες  καµπύλες  παράγονται  αυτοµατοποιηµένα  µε  την  µέθοδο  ενοποίσης
διαρκειών  (βλ.  τεύχος  θεωρτητικής  τεκµηρίωσης),  εφόσον  είναι  διαθέσιµες  ετήσιες
χρονοσειρές  µεγίστων  βροχοπτώσεων.  Οι  ετήσιες  χρονοσειρές  µεγίστων
βροχοπτώσεων  µπορούν  να  παραχθούν  µε  χρήση  της  επεξεργασίας:  «Ανάλυση
εξαιρετικών υδρολογικών γεγονότων». Τα βήµατα που ακολουθεί ο χρήστης:

1. Άνοιγµα των σχετικών χρονοσειρών.

Ο  χρήστης  θα  διευκολύνεται  αν  φορτώσει  τις  χρονσοσειρές  σε  αύξουσα  σειρά  της
διάρκειας  βροχόπτωσης  (όπως  στο  παραπάνω  παράδειγµα  όπου  οι  χρονοσειρές
είναι  ταξινοµηµένες  κατά  διάρκεια  d=5,  10,  30  λεπτά,  1,  2,6,12,24  ώρες).  Η
µεταβλητή  των  χρονοσειρών  θα  είναι  είτε  το  ύψος  βροχόπτωσης  σε  mm  είτε  η
ένταση σε mm/h.

2. Επιλογή του µενού Hydrology→Ombros - IDF curves:
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3. Ανοίγει το παράθυρο επιλογής των χρονοσειρών:

Ο  χρήστης  πρέπει  να  καθορίσει  αρχικά  την  µεταβλητή  των  χρονοσειρών:  ύψος  σε
mm (Height) ή ένταση βροχόπτωσης σε mm/h (Intensity). Ο τύπος της µεταβλητής
πρέπει  να  καθοριστεί  πριν  τον  ορισµό  των  χρονοσειρών  καθώς  οι  χρονοσειρές
ανάγονται επιτόπου σε χρονοσειρές έντασης. 

4. Στην  συνέχεια  επιλέγει  από  την  αριστερά  λίστα  διαθέσιµων  χρονοσειρών,
καθορίζει την διάρκεια του επισοδείου (Duration) είτε σε λεπτά (Minutes) είτε
σε  ώρες  (Hours).  Ένα  επιπλέον  χαρακτηριστικό  που  µπορεί  να  τεθεί  είναι  η
χρονική ευκρίνεια (Time resolution, βλ. τεύχος θεωρητικής τεκµηρίωσης), αν
δε είναι άγνωστη το κουµπί Time resolution unknown παραµένει ενεργό.
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Με  την  χρήση  του  κουµπιού  Add  οι  χρονοσειρές  µεταφέρονται  στην  λίστα  των
χρονοσειρών  που  θα  χρησιµοποιηθούν  στην  ανάλυση  (IDF  Time  series),  ενώ  µε
χρήση του κουµπιού Remove ο χρήστης διαγράφει χρονοσειρές από την δεξιά λίστα.
Για  κάθε  µία  από  τις  χρονοσειρές,  εκτός  της  διάρκειας  και  της  χρονικής  ευκρίνειας
είναι  δυνατόν  να  καθοριστεί  η  χρήση  ή  µη  στις  σχέσεις  για  τα  η,  θ  (Use  for  Eta,
Theta)  και  για  την  εκτίµηση  των  παραµέτρων  της  στατιστικής  κατανοµής  (Use  for
Distrib. fit).

5. Μερικά  ακόµα  χαρακτηριστικά  που  ελέγχουν  την  ανάλυση  είναι  η  ρητή
αποδοχή  τιµών  η  και  θ  (Explicit  set:...)  οπότε  οι  παράµετροι  η  και  θ  δεν
υπολογίζονται αλλά λαµβάνονται µε τις τιµές που θέτει ο χρήστης. Ο έλεγχος
συνέπειας  των  χρονοσειρών  µπορεί  να  απενεργοποιείται  µε  το  κουµπί  "
Consistency check". Τέλος  ο  χρήστης  µπροεί  να  τροποποιήσει  το  ποσοστό
των  τιµών  που  χρησιµοποιούνται  για  την  εκτίµηση  του  η  και  του  θ  (Desired
amount of records used, προκαθορισµένη τιµή στο 33% - 1/3).

6. Πατώντας  το  κουµπί  IDF  Analysis...  πραγµατοποιείται  η  ανάλυση  αφού
γίνουν  κάποιοι  τυπικοί  έλεγχοι  συνέπειας  και  εφόσον  το  πλήθος  των
χρονοσειρών το επιτρέπει:

7. Το παράθυρο των όµβριων καµπυλών ανοίγει:



Υ∆ΡΟΓΝΩΜΩΝ122

(c) 2009 Εθνικό Μετσόβιο Πολυτεχνείο

Στην πρώτη καρτέλα που εµφανίζονται στο παραπάνω σχήµα, ο χρήστης µπορεί να
σχηµατίσει  παλλαπλά  γραφήµατα  σε  προκαθορισµένες  περιόδους  επαναφοράς  (2,
5, 10, 20, 50, 100, 200, 500, 1000, 10000 και 100000 έτη).

8. Στην  δεύτερη  καρτέλα  ο  χρήστης  καθορίζει  συγκεκριµένη  περίοδο
επαναφοράς  (π.χ.  120  έτη)  και  πατάει  το  κουµπί  Calculate  στο  κατόπιν.
Σχεδιάζεται  η  καµπύλη  καθώς  και  η  εξίσωση  που  αντιστοιχεί  σε  αυτήν  την
περίοδο  επαναφοράς.  Στην  συνέχεια  ο  χρήστης  µπορεί  να  παράγει
διαστήµατα  εµπιστοσύνης  για  την  όµβρια  καµπύλη  µε  µεθοδολογία  τύπου
Monte-Carlo (ο χρήστης χρησιµοποιεί το κουµπί Calculate µέσα στην περιοχή
 Confidence interval for a):
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Ο  πίνακας  κάτω  από  το  γράφηµα  της  όµβριας  καµπύλης  περιέχει  τα  σηµεία  της
καµπύλης και των διαστηµάτων εµπιστοσύνης. Είναι δυνατή η αντιγραφή του πίνακα
στο πρόχειρο (clipboard) και κατόπιν σε λογισµικό τύπου Microsoft Excel.

9. Στην  τρίτη  καρτέλα  εµφανίζεται  η  γενικευµένη  εξίσωση  των  όµβριων
καµπυλών (IDF curves equation), η ονοµασία της συνάρτησης κατανοµής, οι
παράµετροι της στατιστικής καταανοµής (Statistical distribution parameters
), οι παράµετροι η και θ (Eta, Theta) καθώς και τα στατιστικά χαρακτηριστικά
του ενοποιηµένου δείγµατος (βλ. τεύχος θεωρητητικής τεκµηρίωσης).
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10.Στην  τέταρτη  καρτέλα  ο  χρήστης  ελέγχει  την  προσαρµογή  της  θεωρητικής
στατιστικής  κατανοµής  στο   δείγµα.  Από  την  λίστα  Displayed  durations
γίνεται η επιλογή των διαρκειών που θα εµφανίζονται στο γράφηµα:
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11.Ο  τύπος  της  στατιστικής  κατανοµής  που  εφαρµόζεται  στην  ανάλυση
καθορίζεται µέσου του µενού Distribution:

Η προκαθορισµένη επιλογή είναι η ΓΑΤ-µεγίστων µε καθορισµένη τιµή παραµέτρου κ
και  µέθοδο  L-ροπών  (βλ.  τεύχος  θεωρητικής  τεκµηρίωσης)  -  GEV-Max  (kappa
specified,  L-Moments).  Μέσω  της  επιλογής  "Specify  GEV  kappa  (shape)",  ο
χρήστης µπορεί να τροποποιήσει την προκαθορισµένη τιµή κ=0.15

12.  Ο χρήστης µπορεί να συµπεριλάβει στην ανάλυση την επίδραση της χρονικής
ευκρίνειας.  Η  επιλογή  γίνεται  µέσω  του  µενού  Options→Consider  time
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resolution effect:

Επιπλέον λειτουργίες ελέγχονται µέσω των εξής επιλογών µενού:

• File→Print... : δυνατότητες εκτύπωσης των γραφηµάτων

• File→Single  IDF  curve  evaluation:  εκτίµηση  όµβριας  καµπύλης
συγκεκριµένης περιόδου επαναφοράς µε την κλασσική µεθοδολογία (ελάχιστα
τετράγωνα)

• Edit→Copy...  :  αντιγραφή  των  πινάκων  και  των  γραφηµάτων  στο  πρόχειρο
αρχικά  (clipboard)  και  σε  λογισµικά  κατόπιν,  π.χ.  τύπου  Microsoft  Excel  ή
κειµενογράφους (Word processors).

• Options→Papers  (distribution  plot):  χαρτιά  κατανοµής  για  την  σχεδίαση
των συναρτήσεων κατανοµής τα ίδια ακριβώς µε την µονάδα «Πυθία».



Μέρος

Γραφήµατα
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8 Γραφήµατα

Το  λογισµικό  υποστηρίζεται  από  λειτουργίες  παρουσιάσης  των  δεδοµένων  των
χρονοσειρών σε µορφή γραφηµάτων:

Ο χρήστης µπορεί να απεικονίσει ταυτοχρόνως πολλές χρονοσειρές επιλέγοντάς τις
και  ακολούθως  πατώντας  το  κουµπί  γραφηµάτων.  Η  επιλογή  µπορεί  να  γίνει
ταυτοχρόνως  σε  πολλές  χρονοσειρές  ή  διαδοχικά  οπότε  και  οι  χρονοσειρές
προστίθενται στο γράφηµα.
Στην συνέχεια ο χρήστης µπορεί να επιλέξει τον τρόπο απεικόνισης των δεδοµένων
(γραµµικά γραφήµατα - µπάρες, µεγεύθυνση, πάχος στοιχείων γραφήµατος, χρώµα,
κλπ).

8.1 Προσθήκη χρονοσειρών στα γραφήµατα

Από το βασικό µενού επιλογή View→Add timeseries to graph.
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2. Το  αποτέλεσµα  είναι  να  παρουσιαστεί  γράφηµα  της  ενεργής  χρονοσειράς,
όπως φαίνεται και στην παρακάτω εικόνα.

Ο  χρήστης  µπορεί  να  επαναλάβει  την  παραπάνω  διαδικασία  για  να  προσθέσει
επιπλέον χρονοσειρές στο γράφηµα.

8.2 Αφαίρεση χρονοσειρών από τα γραφήµατα

Η  αποµάκρυνση  της  ενεργής  χρονοσειράς  απο  το  γράφηµα  γίνεται  µε  επιλογή  του
εργαλείου View→Remove timeseries from graph.



Υ∆ΡΟΓΝΩΜΩΝ130

(c) 2009 Εθνικό Μετσόβιο Πολυτεχνείο



Ευρετήριο 131

(c) 2009 Εθνικό Μετσόβιο Πολυτεχνείο

Ευρετήριο
- A -
aggregation     46, 49
autocorrelation     82

- B -
basin simulation     90
blaney - criddle     58

- C -
chezy     75
complex calculations     50
construction of discharge - sediment discharge
curves     68
construction of stage - discharge curves     68
copy - paste     25
correlation     82

- D -
data check     38
discharge - sediemnt dischare     65
double mass curve     51

- E -
evaporation     58
evapotraspiration     58
extreme rainfall time series     117

- F -
filter     28
flags     31
forecast     108

- G -
graphs     128

- H -
help     5

highlight     28
homogeinity test     51
hydraulic curves     75
hydrological calculations     58
hydrometry     98

- I -
idf curves     117, 119
infilling     82
intensity duration frequency curves     119
irregular to strict     45

- L -
linear combinations     48
linear regression     82

- M -
manning     75
Multi time series selection     42

- O -
objective function     90
ombre     119
online help     5
open channel     75
optimization     87
options     5
out of range values     38

- P -
penman     58
penman - monteith     58
percolation     90
popup menu     34
pythia     108

- Q -
quick sum     28

- R -
rain-runoff model     90
range check     38
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regression     82
regularize time step     43

- S -
set flags     31
stage - area, volume curves     62, 79
stage - discharge     65
stage - discharge curves     62
statistics     108
stout     65

- T -
thornthwaite     58
time consistency check     39
time series operations     42

- Z -
zigos     90
ακανόνιστο χρονικό βήµα     43, 45
ακραίες τιµές     38
ανάγνωση από αρχείο     21
ανάγνωση από την βάση     21
ανάλυση εξαιρετικών υδρολογικών γεγονότων     117
ανοικτός αγωγός     75
αντιγραφή     25
αντικειµενική συνάρτηση     90
απεικόνιση δεδοµένων χρονοσειρών     9
άρση χρονικών ατελειών     43, 45
άρση χρονικών ολισθήσεων     43, 45
αυτόµατη σύνδεση     5
αυτοσυσχέτιση     82
αφαίρεση χρονοσειρών από γράφηµα     129
βελτιστοποίηση     87
βοήθεια     5
γενικά     2, 4
γλώσσα     5
γραµµικές πράξεις     48
γραµµικοί συνδιασµοί     48
γραφήµατα χρονοσειρών     128
δηµιουργία νέας χρονοσειράς     18
διαστήµατα εµπιστοσύνης     108
διεργασίες λεκάνης απορροής     90
διπλή αθροιστική καµπύλη     51
δυνητική εξατµοδιαπνοή     58, 90
εγγραφή σε αρχείο     21
εγγραφή στην βάση     21
εικόνα χάρτη     5
εισαγωγή     2, 4

εισαγωγή νέων εγγραφών     23
έλεγχοι δεδοµένων     38
έλεγχος ακραίων τιµών     38
έλεγχος οµοιογένειας     51
έλεγχος χρονικής συνέπειας     39
ελλείψεις     46
εµπειρικές κατανοµές     108
εµφάνιση λογισµικού     5
ενοποίηση διαρκειών     119
εξάτµιση     58
επέκταση δειγµάτων εξατµοδιαπνοής     58
επεξεργασία δεδοµένων     25
επεξεργασία τιµών     9
επιβεβαίωση εξόδου     5
επικόλληση     25
επιλογές     5
επιµερισµός χρονικού βήµατος     49
επισήµανση     28
εποχιακή συνάθροιση     46
εύρεση τιµών     28
ζυγός     4, 90
ιδιότητες χρονοσειράς     18
καλιµπράρισµα χάρτη     5
καµπύλες επέκτασης καµπυλών στάθµης - παροχής
    75
καµπύλες παροχής - στερεοπαροχής     62, 65
καµπύλες στάθµης - επιφάνειας, όγκου ταµιευτήρα    
62, 79
καµπύλες στάθµης - παροχής     62, 65
καµπύλες υπόγειων διαφυγών ταµιευτήρα     62, 79
κανονική κατανοµή     108
κανονικοποίηση χρονικού βήµατος     43, 45
κασταλία     4
κατανοµές     108, 119
κατάρτιση καµπυλών παροχής - στερεοπαροχής    
68
κατάρτιση καµπυλών στάθµης - παροχής     68
κατάρτιση χρονοσειρών µεγίστων     117
κατείσδυση     90
µενού συντόµευσης     34
µοντέλο βροχής απορροής     90
νέα χρονοσειρά     18
νέες εγγραφές χρονοσειρών     23
οδηγίες     2
όµβριες καµπύλες     117, 119
όµβρος     4, 119
οµογενής ευθεία     82
οµογενοποίηση δεδοµένων     51
οργανική συσχέτιση     82
παραγωγή χρονοσειρών µεγαλύτερου χρονικού
βήµατος     46
παραγωγή χρονοσειρών µικρότερου χρονικού
βήµατος     49
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παραµετρική εξίσωση εξάτισης     58
παραµέτροι στατιστικών κατανοµών     108
παρεµβολές χρονοσειρών σε καµπύλη     62
περιβάλλον επεξεργασίας χρονοσειρών     8
πολλαπλά γραφήµατα     128
Πολλαπλή επιλογή χρονοσειρών     42
προβολή σηµαιών     31
πρόγνωση     108
πρόσθεση χρονοσειρών     48
προσθήκη χρονοσειρών σε γράφηµα     128
προσοµοίωση λεκάνης απορροής     90
πυθία     4, 108
ροή µε ελεύθερη επιφάνεια     75
ρυθµίσεις γλώσσας     5
ρυθµίσεις χάρτη     5
ρύθµιση µοντέλου     90
σηµαίες     31
σηµαιοθέτηση     31
στατιστικά τεστ     108
στατιστικά χαρακτηριστικά     108
στατιστική ανάλυση     108
στατιστική πρόγνωση     108
συµπλήρωση     82
συνάθροιση     46
σύνδεση κατά την εκκίνηση     5
σύνθετες πράξεις     50
σύντοµο άθροισµα     28
συσχέτιση     82
τυπικές υδρολογικές επεξεργασίες     58
τυχαίος όρος     82
υδρογνώµονας     4
υδρογνώµων     4
υδρολογικό έτος     46
υδροµετρήσεις     68, 98
υδροµετρία     98
υπολογισµός εξάτµισης     58
υπολογισµός παροχής από στάθµη     62, 65
υπολογισµός στερεοπαροχής από παροχή     62
φίλτρα     28
χάρτης, ρυθµίσεις     5
χειρισµοί χρονοσειρών     42
χρονοσειρές µεγίστων βροχοπτώσεων     117
χρονοσειρές παροχής     98
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